Person Detection taking about 15 minutes before I get notification to my personal phone

Person detection is working now with my 4 Wyze cams but it’s taking too long to send notification to my personal smartphone.
How can we fix this issue?

A little more information is required, what kind of phone, what version of the app and what time frame are you getting the notifications in currently.

I got Samsung Galaxy J7 Refine.
It takes 15 to 30 minutes to notify me of person detection.
That can be scary. A burglar has hit and ran before I get notified.

Does it always take that long or just at certain times?

I’ve had the same problem for over a year. I have a pixel 3xl and it can take from 2 to 15 mins to get a notification when the phone is locked. If I unlock the phone the notifications come rolling in. App is allowed to run in background and battery optimization is not on. Spent months working with Wyze support last year to no avail. If I use and old android phone the notification comes thru within 20 secs or less. Within the last two weeks I installed home assistant and a DIY alarm system. Had the same problems with notifications until I added two lines of code to send the notification as High Priority. Now they come thru instantly regardless if phone is locked or not. Do not understand why Wyze can’t seem to implement the same solution.

I have this problem with multiple apps, actually one of the apps I experience the delayed notification issue happens to be GMail and while searching other websites about that it led me to a doze issue in a version of Android that you either have to run a shell command at every boot or root your phone and disable. I have disabled doze using the shell command and it fixes it instantly.

Check your phone’s Settings -> Battery section, specifically the Sleeping section.

Glad it works for you … I have tried that and everything else I could find for the last year. Changing my home assistant notifications to Priority is the only way I have solved this. Unfortunately the Wyze sense devices to not work well with home assistant ( at least not yet).

It only works when I run the shell command and I hate doing that so I get delayed notification from many apps when I pick up the phone.

Sorry for delayed response.
Found out that notification pops out instantly on my iPad.
But with my company cell - Samsung Galaxy J7 Refine - it’s still taking about 15 minutes or sometimes it does not notify.
By just connecting both devices to my home WIFI LAN and the result are still the same.