Pan Cam not keeping position

#1

I just realized that my Pan Cam resumes the initial starting position after I have aimed it elsewhere with the app.
After closing the app or simply switching to another camera, then returning to the Pan Cam, I see it immediately move back to the starting position.
I would appreciate having it remain in whatever position I choose and only have it return to default when I explicitly choose so.
I’m on the latest beta but not sure if this has been the behavior all along…

2 Likes
#2

You have to set a single waypoint for it. Check out the link below. Let me know if this helps.

#3

Waypoints are good when you know in advance where to expect motion but with Motion Tracking and Pan Scan both off, I would have thought the camera would remain in the same position till I move it again.

#4

Check detection settings, detection zone and see if it is on. This forces it to return to the position set when the detection zone was defined.
I have the opposite problem on some of my pan cams - it won’t return to the detection position.

1 Like
#5

It returns to it’s home position after 15 seconds so you don’t have to do it yourself.
The idea is you can move the camera around to take a look at the surroundings then have it return to the position you previously set as home.

To expand on what tomp said; You can set a new home position by going to the Detection settings, Detection zone. Turn Zone on, point the camera and leave settings.

#6

Thanks tomp. Disabling detection zone gives me the desired behavior - “don’t move unless I say so”

2 Likes
#7

Great! Let me know if you start having my issue with it not returning or if you hear of a fix.

#8

@tomp Do you have waypoints set?

#9

Yes. But pan scan is turned off. Just set the waypoints to test scan and don’t use scan on a regular basis.

#10

Is your camera returning to one of those waypoints by any chance? When I had several waypoints set up, it would always return to the one that I had “highlighted”. I don’t use pan scan or motion tracking, but I set up just 1 waypoint, where I wanted the camera to always go “home” to. I also set my detection zone there. Now the camera sits there and if I manually pan it around in the app, after 15 sec of no activity, it always returns where I want it. If you aren’t using pan scan, trying deleting your waypoints and setting just the one and see how that goes. Good luck!

#11

If you have set a waypoint, and Pan Scan is turned off, then the camera ignores that waypoint until Pan Scan is turned on again. However, if you have a detection zone set, and Pan Scan is turned off (BTW, they can’t be used simultaneously), then the Pan will center on the detection zone.

1 Like
#12

I have been experimenting a bunch and this is what I am finding and I know it causes a lot of frustration with people: If I have MULTIPLE waypoints set, detection zone OFF, and NO pan scan or motion tracking, when I manually pan around it always returns to the whichever waypoint I “clicked on” before I hit the Save button in the waypoints. It also turns ON detection zone and sets that particular waypoint as your detection zone (have to close the app and go back in to see that it has done that), even though I had it OFF.

Since I don’t pan or track, to relieve the frustration of it not returning where I want it, I leave it with 1 waypoint and that is also my detection zone, and I have had no problems. In my opinion, if you don’t ever use the pan or tracking feature, don’t set multiple waypoints. Either use detection zone or 1 waypoint so it will stay put and always go back to that spot.

If you want multiple waypoints because you occasionally turn the scanning on, be sure to click on the one you want as your “home” position before you hit the Save button when you set them up. That’s what my experimenting tells me.

EDIT: One more experiment. Set 4 waypoints. Clicked on the one I want as my “Home”, then clicked Save. It automatically turns on my detection zone for that waypoint. I turned on Pan Scan, let it pan a few times. Turned it off on one of my “non-home” waypoints. It stayed there and did not return home. Of course, it is known that turning on pan scan turns off detection zone. I went back into detection zone in the settings nd toggled the switch back on and it returned to my “home” waypoint.

1 Like
#13

Interesting. Thank you for sharing that!

#14

Maybe it will help someone, or maybe I’m the confused one, LOL.

#15

I have already tagged some devs so they can read about your observations. :slight_smile:

1 Like
#16

I added an edit to the bottom of my post about one more observation. Also, I am on Android Galaxy S8, beta, pan 4.10.3.40, app 2.2.19.

1 Like
#17

I do something similar except I do it through Detection Zone.
Go to Detection Zone. Pan your camera until you find the location you want to be your “Home” position then just exit out.

2 Likes
#18

But, again, whichever waypoint I clicked on before I pressed Save in that section (if there is more than 1 waypoint), no matter where I try to set my detection zone, as soon as I close and re-open the app, it goes back to that one waypoint and changes that to the detection zone. I must choose the waypoint I want as home before clicking Save in that section. The only other choice is to have no waypoints and set a detection zone, or just have 1 waypoint centered on where you want it (which also then becomes your detection zone). That’s how it is working on mine. Again, I have no trouble whatsoever with it, just trying to explain what I’m finding so it could possibly help some of the others who can’t get it to sit where they want it. :slight_smile:

#19

Tsatrans - great detective work! And very helpful. I tried deleting each waypoint in pan scan and turning it off, then turning on detection zone and setting my zone with no waypoints set. No avail - when I pan from the app with zone on it stays where I leave it.
If I use your workaround and set one waypoint where I want my detection zone to be but have detection zone off then pan from the app and stop out of the zone/waypoint it almost immediately returns to the waypoint. No 10 second delay-maybe 3-4.
I have a total of 5 pan cams and 3 act the same way. The other two work as described- set the detection zone and they return to it.
All are firmware updated and I am on IOS Beta app 2.2.18.
I had the same problems before I went to the beta app but never got to dig this deep into it. Great to see the responses - maybe this thing will get figured out!

#20

Strange, isn’t it?! If I read it correctly, are you saying you are at least able to get it to return to the spot you want it at now (by setting one waypoint)?