Observations on Notifications

I have noticed the following with notifications and in the past have submitted logs on this, which I was told are being reviewed and worked on. However, I am seeing other things which I wanted to post and get others perspective on it.

First, let me say I am on an Android phone as my daily driver and have an iPhone as my test device as well. They all are on the latest Beta / RC release.

Also let first state that I am a fan of the Wyze products and find that notifications have gotten a lot better. I know it can even get better which is why I am providing my experience and asking questions. I am striving to assist in making Wyze’s process better and not bash Wyze. So please don’t take this opportunity to provide a bunch of negative comments about wyze. lets simply share our experience with details so that we can hopefully assist with the time it takes to get notifications.

  1. Notifications seem to take an average of 20 to 45 seconds when you have CamPlus on. With CamPlus off, I normally get alerts in less than 10 seconds.

  2. I have recently noticed that when the events show LIVE in red, indicating there is something happening and it is still recording. When you are in this state, there are times when I don’t get any Alert until LIVE goes away. So the Alerts seem to be delayed more than it probably needs to be. In addition, on some occasions, the LIVE will stay there much much longer after the event has passed. This will cause a 5 Minute Event, but maybe a 55 second Play time when you click on it.

  3. I know CamPlus has AI processing needing to be done, so I expect some lag in notifications. However, wondering if any of these options are available, as it seems as if it waits until the entire process is done checking before your are notified:

    • If you have Notification set for All Motion and AI, set the system to notify immediately when motion is detected, you can add the AI info afterwards. Treat it as no CamPlus and do the AI in the background.

    • If you only pick All Motion, then notification should be as fast as if you did not have CamPlus activated. However, it seems by having the CamPlus activated causes the same slowness. I use the CamPlus on the Doorbell to not limit the recording, but have it set for All Motion and not AI. My door does not face a road, so there is not real issue with doing this, I simply want more than 12 seconds. However, Even though I only have All Motion set, I still get delayed notification and some are tagged as person. Again, treat as no CamPlus, but allow more than 12 seconds.

    • If you have AI notification only, then notify immediately when it is determined what is found. It seems to take the same amount of time no matter which you are checking for: Person, Vehicle, etc. If it sees any of the AI options are found then alert, don’t wait until all AI processing has been completed. Continue the process in the background and update the tags afterwards.

Here is one of my examples: In the mornings, My wife goes to workout, I can see her walk out of the garage cross in front of the Driveway cam, close the garage door, go back in front of the camera, down the driveway and walks out of site. that whole time the Driveway Cam event shows it sees her, but does not alert until there is no more motion. this is similar to item 1 above. When I look at the Camera, it says LIVE on it, it sees her, but nothing until the event ends or the system is satisfied it is ready to alert. To be fair, sometimes it will alert before she gets off the driveway, but not always.

So curious on what your experiences have been and if they are the same as mine. I am sure that not everyone has been tracking some of the Alerts to determine if there is a pattern, but heh I enjoy this process. :slight_smile:

Again, Kudo’s to Wyze on what they have accomplished in such a short time and the quality of what has been provided. Yes, there can be improvements, but I am confident they will come.

2 Likes