Nothing but problems with Wyze Headphones

I’ve been a Wyze fan since their first camera and I am always a first adopter if their new product fits my needs. This was the case with the headphones. Overall they sound great and are the most comfortable noise cancelling headphones that I own (are you listening Sony?) but I’ve had nothing but problems with them. I connect mine directly to my LG tv and they get hours of daily use.

When I first got them, they would mute on their own seemingly at the tilt of my head. As often as not the only way I could get the sound back was to take them off for a few seconds then put them back on and hope they reset. Other times I would have to turn them off and back on to get them to work. I turned off all the auto-muting stuff in the app and haven’t had that problem since.

The one time that I needed to fold them up to pack them for a trip, one side of the plastic casing exploded when I folded the headphones. I taped them back up best as I could and they still work well enough and I’m not worried about how they look but now, for absolutely no reason that I can discern, the noise cancelling now turns itself off randomly. There is no beep, no going thru transparency mode, it just flat out turns noise cancelling off.

I’m really disappointed in these headphones. I’ve never had a single problem with any other Wyze product so this is also rather surprising. Based on my experience with these headphones, I won’t be buying the ear buds anytime soon.

TLDR: I’m wondering if anyone else is experiencing the random turning off of the noise cancelling while wearing the headphones.