Not supporting older iOS

I just saw a banner when opening up the app about NOT supporting lower IOS. Something about IOS 14.

Please DO NOT do this. I run IOS 13.5 because I HAVE to, I cannot upgrade because of apps I need for work. I have 25+ wyze devices.

If you lock me out of the app for frivolous upgrades I will go ballistic. I’ve been a customer since the beginning and own MOST of the products.

An IOS lockout will cause me to lose functionality of hundreds of dollars. I will be unable to use all my devices. This is ridiculous. The system works now under my software. Causing it to fail on my in the future is tantamount to stealing. You can’t steal my products and functionality after I have purchased them.


I am a big evangelist of Wyze, telling everyone I know. Don’t make me change my narrative to avoid this company,

This notification from June 2021 states you need iOS 12 or above. I have not seen anything that states anything different. As far as your stealing comment I guess people that have/had 3g phones on AT&T and soon to be Verizon should make those companies give everyone a new phone because they will not now or in the near future work when 3G no longer exist. :rofl:

1 Like

The banner popped up today on my phone which is on Ios 13 It did not pop up on my ios 14 tablet.

Call WYZE and ask them, I see no announcements that you need iOS 14 or higher, the notice I posted says 12 or higher. WYZE phone: 206-339-9646

1 Like

I’m guessing that unless you run 13. You will not get the banner. I got it once. I posted here to reach out, I’m guessing calling them would be a meaningless enterprise down a rabbit hole eventually reaching someone who had no idea.

Just go spend a $150.00 on a refurbished iPhone 8 and add iOS 15.4 to the phone and be done with your issue. it’s only :heavy_dollar_sign: :heavy_dollar_sign:

Why would I go down 4 models on my iphone? Why would I want to carry two phones? I don’t think you understand the issue, Antonius.

I understand the issue. You are using a 22 month old version of iOS because the apps you need for work won’t work with iOS above 13.5. Maybe you should contact the makers of those apps and tell them to get with the program and update their apps. then all would be well . :upside_down_face:

I wish I knew what you saw. I have an iOS 13 iPad myself (also because of an old app - a game), but I run the Beta app on it. It did not give me this prompt when I ran it just now. I also haven’t heard anything about needing more than iOS 12, so I wish I could see that message.

1 Like

I almost missed it, popped up once for a second and hasn’t popped up since. It basically said something to the effect that I need to upgrade the app and it will no longer be supported under 13, and needs to be 14 to take advantage of “new features” I don’t care about.

The app works now, if they force me to upgrade I will pick my phone over the entire ecosystem and it will cost me a chunk of change. Sigh.

The banner popped up for me today on a device running iOS 15.4. :thinking:

It appears that the pop-up is indiscriminately displayed upon 1st run of app version 2.29.1 (a6).

I haven’t seen it yet. Maybe it’s the ghost of the WYZE future. :astonished:

1 Like

Do you have a copy you can share?

I didn’t screenshot it… I figured everyone must be seeing the same thing and I ignored it.