Not all notifications work on wyze watch

The notifications on wyze watch only work for. Phone calls and the native messages app on an android. Ife verified do not disturb is turned off everywhere, notifications are turned on, the app is authorized, Wyze is running in the background. I’m not even getting notifications from wyze…
I’ve conferred with another user they are able to get notifications just fine, Google voice was a big one for me. They were getting those notifications. I am not. I have a wyze band that notifications worked fine on, including Google voice. I removed the band to troubleshoot, no good.

Anyone else having this issue?
Galaxy note 10, android 11

I use a Pixel 5 and have not experienced this issue. My only issue with notifications is with the EMail. I and others only get the from and to information and no subject or body of email.

@spamoni4 I too am only receiving the email address from and not the body of the email. Not sure if this is to be expected. I’m also having issues with my text notifications coming in. The text body displays, but instead of name it shows the phone number. Thoughts?

To get the name, go into “other Applications” and select the messaging from there and disable the one on the main page.

@Spamoni4 I’m using Samsung Messages for my text messages and it is not showing up for App Permissions.

I would open a ticket or report this as a bug and send the log in. There are a number of other items they will need to fix, like the GMail issue with showing the subject and message preview.

I tested and set the default message and it shows the Phone number, but when I choose the Message app in other applications, it shows the name.

Curious, did you provide the Wyze app permissions to see your contacts? I have, it still shows the phone number only, but may be different on your phone.

I use a Pixel 5, so my settings are a bit different.

I opened a ticket and sent a log last week. Haven’t heard back. I asked for an update once and got an auto response that they are busy and covid etc… still waiting.

Mike Jorgensen

That seems to be the standard answer. I have found calling is better sometimes.

I’ll give them a call. Thanks!

Mike Jorgensen

1 Like

I figured it out. In settings go to apps, then tap dots in top right corner, tap on special access. Scroll down to notification access, scroll down to Wyze, you will see two options for Wyze. One was toggled to not permitted. Toggle it on and I started getting notifications on my watch. Not Outlook, but text to Google voice (not the actual text message) . Now I’m at least in the same boat as the rest of you.

7 Likes

I’m using Samsung Messages and am still experiencing same issue after your recommendation. However, Google Messages does work. shrugs

iPhone user and Wyze notifications do not work with my Wyze watch. I get text messages and that’s it. Messenger notifications don’t work. The Bluetooth range is about 4 ft. Any further from the phone and the watch doesn’t pickup any notifications. Even with all settings set to keep it connected and run in the background, it continually disconnects from Bluetooth and I have to manually reconnect. It does not auto connect when it’s close to my phone. To be honest I am extremely disappointed in this device as I expected more functionality than a fancier Fitbit

I get notifications for everything on my band, but the watch i only get messages. None of the “other apps” or wyze events come through.

Also, there’s no option for increasing the vibration intensity or heart rate check interval like there was on the band.

So far it seems like it runs great, minus those missing features.

I put in a ticket for the notifications though

[SOLVED]

Solved it on my Android (Google Pixel 3)!
I was receiving notifications for calls and texts, but nothing else (though I had allowed notifications from other apps like Facebook Messenger within the Watch settings in the Wyze app).
I went to Settings>Apps and Notifications>Special App Access>Notification Access. There was a list of apps with special notification access and Wyze was listed twice. One toggled on and one toggled off. I toggled them both on and so far, I’ve received all notifications from Messenger (and I presume all the others I’ve selected will work too, once I get notifications from those apps on my phone).

5 Likes

I’ve seen this fix before, unfortunately on pixel 4 i dont have a special app access menu. I have every notification option enabled, but no avail.

open settings then search for special. It should be there, it is on my pixel 4a5g

Found it that way, but it just brought up the same menu i was in before

4 Likes

Yeah, that was the same menu path as on my Pixel 3.

Thank you!!! Spent days trying to make this work, it drives me crazy.