NO HELP from support, Anyone else cant access their wyze web subscriptions? (‘500 Internal Server Error’)

Wyze support is absolutely useless for my case, they aren’t even responding to me anymore.

Keep Getting ‘500 Internal Server Error’ when trying to visit Wyze Home Monitoring Service to edit subscriptions

Wyze live chat basically told me tough luck they cant do anything, wyyze support on forum just keep saying they “have informed the internal team to check” its been over two weeks I was thinking of maybe upgrading to the unlimited cam plus, but now I just want all my existing plans to be canceled when they expire next week!

I cant believe this, Even told my friend to try from a different country and still the same error!

When you say Wyze Web Subscriptions, are you saying your account from a browser or from your app?

Sorry just realized the link you provided is the services link. I checked with my account and it loads fine. What Browser are you using? Have you tried clearing your Cache?

I use a Chromebook with Google as the Browser

1 Like

tried everything, different browsers, devices, OS, countries, VPN, incog, etc…

I have seen from the forum that several people have faced this issue over the years, but no update on if it was resolved.

The live support said cant do anything try again, other times they said they have contacted their cloud team because they recentley changed settings, but no reply.

Also, one agent asked whats my timezone, I told them, its outside the USA (though I manually changed my time and made no difference). Even then no response after that, so frustrating! I have an auto renewal on next week and I need to cancel and I cant access it…

Sorry to hear that,

Do you have any add blockers or some type of security around websites?

Try on your phone and put it on Cell Service and see.

1 Like

Already tried, no difference. Even diffent wyze accounts.

@carverofchoice @R.Good

Do either of you have any additional suggestions on this?

Maybe a country or ISP level block or transparent proxy. Although the corroboration from the remote friend doesn’t add up.

You could try accessing it by IP address I suppose. What server is returning the 500 error? Could you post a screenshot?

I am having the same issue. Tried different browsers, clearing all internet data, incognito mode. Continuously getting the error trying to click on “manage wyze services”

Lol they just fixed it for me a few days ago.

Desmond from wyze was the one I talked to, didn’t say why it happmed just said should be fixed now after weeks of pestering.