No circuit board for Wyze Thermostat

The only two wires coming from my transformer are purple and gray. Each of those I had to follow his instructions and connect to my thermostat wires, as well as the other thermostat wires I had to connect.

I suggest taking pictures of your exact setup and posting them. That should make it easier to find your solution.

They do now. Years ago, I only had the two red and white wires hooked up that go to another control box on the furnace. Those two wires went to a plain non powered mercury thermostat. It simply turned the heat on or off. Then at some point a few years ago, I wanted a programable thermostat to run a schedule and also to run just the fan if I wanted. So I hooked up the ones you saw in my picture so I could do that. When I just got the Wyze, I only had to hook up the C wire on that transformer and I used the yellow wire for now since it’s normally used for cool and I don’t have AC.

Perfect. My exact same situation but just with a hydronic boiler. But same setup. Looks like I just need a 3rd wire and I’m good to go. Pulling shouldn’t be a problem. Thanks!!!

Pulled a 3rd wire. Hooked it up to Common. Works! Thanks so much!

1 Like

Can you / someone with similar setup post pics of the adapter connected? I’ve got the same thing going - old unit, no circuit board, and I want to get mine working!

I have red, green, blue, and white wires coming to my current thermostat. Having trouble tracing back to the air handler.

I’ve got a similar setup (no control board), see post below. I think I know how to wire in except for the C wire. Any help would be appreciated!

Wiring issue - no control board at Furnace for C-wire adapter - Ask the Community - Wyze Community (wyzecam.com)

Glad to her it worked out!

Post a picture or make a new thread and i’ll try to help.

I think I have the same issue. I have no circuit board or control board in my HVAC system. The wires that go to my thermostat is blue (Y), green (G), white (L), and red ®. Any help much appreciated!

Here is my post

Got mine hooked up and working today! Essentially treated the wire nuts as the control board and wired accordingly w/help from Speadie. Ended up turning my G into the C back at the thermostat.

Speadie. I would like to ask for your assistance since u seem to be very good at this. I also encountered the same issue as everyone here and realized that my unit has not control board. Once I saw this I didn’t even attempt to loosen anything. I would really appreciate any help or input. Here are pics of my set up.

This is probably C (common).

image

Make sure the power is off.

Wiring your Adapter. Note the wire colors. The letters in the air handler box represent the wire nuts.

3 Likes

Thanks for the quick response. I will attempt to connect this weekend.

I made my own post for assistance, posting here because you all have been so knowledgeable and helpful.

Note: this was resolved. Leaving for archive purposes.

https://forums.wyzecam.com/t/no-circuit-board-for-wyze-thermostat-revolv-eb17d-unit/158794

Speadie, I hope you are still around…

My handler does not have a circuit board…
Any advice from you or others would be much appreciated.

Thermostat is old mercury and has Y, W, G, R.

Post would allow only one picture. Let me know if more are needed.

Would be best to start a new thread, if you have multiple pix, you just need to post multiple replies.

You’ll need the C wire adapter, the brown wire appears to be your C wire, so you just need to add the C wire from the adapter to that wire nut, then follow the app instructions to wire the other 4 wires.

Can you point out which wire goes to the thermostat? Are there any unused wires wrapped around the cable that can be used for C?

1 Like

Do you have heat? Your white wire would normally be heat, but it appears to be connected directly to C, which would cause a short circuit if the heat ever kicked on.