Newfoundland Time Zone Synching Problem

Anyone know any tricks to get your WYZE camera to synch to the Newfoundland Time Zone? It can be done - it is just unclear how.

I almost returned my first WYZE as the half-hour offset was annoying, but it eventually synched. I am not sure how, I only noticed it after it took a fall and I restarted. I bought a second one and now my two cameras are listing in different times. I have tried adjusting the time setting on my device and manually setting my device to be offset by 30 minutes but either way the new camera does not line up with the time I am trying to get it to display.

This is a really annoying bug as it would be an easy fix, but from what I have seen online others have reported it and WYZE does not appear to be interested in fixing it. If the camera is sold in the North American market it should be able to synch to all NA time zones. Or just make it so it is independent of time zone, so that it only on the device’s time.

In the advanced area of the Camera (Settings), there is a Sync Time. I believe this uses your phones time to and syncs to the camera. So, in theory, if you set your phone to any time zone you want and the sync, it should be set to the desired location.

I have not done this, but it may work.

Unfortunately the synching is not reflected in the camera’s time code, I think the timeline on the playback itself reflects the right time, which makes it very confusing. If I set my device time manually to be offset from my time zone by 30 minutes, it still does not synch and remains off by 30 minutes. I somehow managed to get it to synch on my first one - but I do not know how I did it. I had tried the same things previously (synching/restarting/editing time etc) but only noticed things finally synched after I pulled the plug and reconnected it after it took a fall. Still have no idea what worked, only that it can be done. I have seen complaints from others in my time zone about the synch not working and that it has been reported to WYZE and they did not have a solution or intent to update the software. It is pretty silly that I have 2 cams displaying different times right now.

I don’t know how simple or hard this might be to fix, but you have to remember the US is all Wyze markets to ATM, and therefore all their efforts are focused on that. Hopefully when they include Canada they will figure out Newfoundland.

Or is this why they haven’t included Canada yet??? (just kidding, lol!)

From what I understand this is in their excuse book. But it is sold to Canada, and sold in Canadian stores - so this is a weak excuse. Especially as it is an easy programming fix and most products would just program all time zones.

The most irritating thing is that it can be done. I have one camera synched to the appropriate time. I just have no idea how I did it as the actual synch option did not work. The weirdest part is that the timeline on the playback displays the correct time, but the time stamp does not match the timeline. But on my first one I managed to get them to match, which is the only reason why I did not return it. I forgot about the frustration after a few months, and bought a second one, only to remember why I will not be buying more. I wanted to minimize the number of apps that I am running for surveillance - but going forward I will just by from the same series I have for my doorbell.