New RTSP Binaries for Beta Testing

I found the Wi-Fi signal of these has to be MUCH stronger to stop the drop outs. I have tried on multiple routers / AP’s as well. When it is right beside the AP, I seem to have far less drop outs. When I move it one room over, RTSP is almost unusable. The odd thing is, that when I use the Wyze app, it works fantastic real time.

I am going to do a bit more testing, I have used an ASUS RT68U which is no slouch, a Fortinet AP FAPU321EV, and a few others to test. When logged into the AP / Router I can see the signal is quite low compared to every other device at the same distance.

I’ll play around with the Channels too as to rule out interference.

These camera have [Mod Edit] reception over WiFi. I have tried everything under the sun. I have worked in IT for over 20 years. I have a Netgear Nighthawk main router. It wasn’t enough. Bough the new WiFi 6 version, still no go. Got 2 cheap $50 TP-Links. Now and finally got the Wyze app semi stable.

RTSP is “okay,” but not great. Their Wyze Plus service is useless. Went to use it one day and had no video for like a whole week, because these cameras don’t stay connected unless you spend $1000 on network equipment.

My final setup:

Main router is the WiFi6 Nighthawk.

1 of the $50 TP links is connected to it as a separate network and therefore my WiFi 6 Nighthawk is the WAN Port.

The older WiFi 5 Nighthawk is connected the the 1st TP-Link as a Access Point only and then the 2nd TP connects to it as an Access Point.

4 routers total, the 3 are a separate network just for the Wyze Cams, nothing else but them and the PC for the RSTP is on that network. No CAMs are more then maybe 25 ft away from each Access Point and if you check their signal? They all show 0 of 3 bars. I have all 4 2G networks on different channels, used an app to check my area for channel congestion and none of it matter. Cam can be right next to the router, one is, not even 3 feet away. Still not signal. Tried the External Antenna hack, made no difference.

In the end, get what you pay for, cheap $20-30 camera limited to a 2.5GHz network. Next time. I will go PoE and spend more on the cameras. These weren’t worth the time and effort even with the cost and they can’t event make the RTSP a main feature, only Beta Firmware… Cancelling my CAM Pro subs on all 11 cameras as soon as the subs expire. Waste of money. And, support, useless. They can make any claim they want about it being my or your network, it isn’t. Not with how much money in equipment and time I’ve spent configuring these routers, and this is ONLY a 1 story 1400 sq ft house. Before these cameras, 1 router handled the whole house and neighbors across the street can see my network!

MOD NOTE: Post edited to conform to the Community Guidelines.

It is true RSTP is certainly not very stable and therefore for me, the product is not really usable. The strange thing is that everytime a Wyze camera drops on my BlueIris, when I check it in the Wyze App is running… Think the product is good, issue lies with the RSTP over Wifi.

I think it’s just low horsepower. I don’t even use RTSP but whenever there’s an event to process, my live feed is very likely to go dark for a minute.

Hi fellow Wyze RTSP enthusiasts. I’m posting in this thread for two reasons:

  1. To get notifications of changes as I am one of the many RTSP users who would like to see more stability so will be keeping an eye on the updated RTSP firmwares. I initiated an RTSP reliability fault about 6 months ago but got so dizzy from the non-support circle I was put in I stopped replying - presumably this was counted as a success so the call could be closed.

  2. To ask @WyzeTao why there is a delay with the RTSP stream as it seems like it is artificially introduced?

Boy…I’m late to this party.

Does anyone know if this RTSP build fixes:

  1. Ability to set static IP address
  2. Fixes MAC address conversion to base hardware MAC when DHCP lease expires
  3. Adds options to specify RTSP stream quality
  4. Uses a more standard audio format (i.e. MP3 instead of G.711)

What does this build “fix” versus just updating the base firmware would be my main question…

@WyzeTao thank you so much for your work on improving RTSP. It was almost unusable to me before the update. I flashed 4.28.4.49. It has been a great improvement. I use it to monitor my cameras with VLC and Home Assistant on my computer desktop. I get a lot more use out of the cameras this way. I think a lot of people in the Home Assistant community were very discouraged by the state of RTSP because it hardly worked. Any more improvements in stability would be great and a great selling point to those in the Home Assistant community. I think this thread would be great if we could provide more concrete feed back so Wyze can improve the RTSP on the camera.

1 Like

@WyzeTao Also like to send my thanks for continued work on this. This substantially improved my experience on Synology. I do continuous recording in 30 min chunks and prior to these updates, files that should be 30 min end up being like 20 min per VLC but synology thought they were 30 min which caused all kinds of synchronized play back issues in surveillance station.

Now the files are perfect 30 min ones. Not sure what changed RTSP wise but this is huge and was a direct result of new firmware. I still have the connection drop outs sometimes but it seems in those cases just the same frame gets recorded for a bit in synology which makes it the correct overall length. This is mainly be on a camera that is in an area with weak wifi coverage so kind of to be expected.

2 Likes

@WyzeTao I can’t for the life of me get a v2 cam to flash the firmware with any of the following versions:

  • demo_v2_rtsp_4.28.4.49.bin
  • demo_4.28.4.50.bin
  • demo_4.28.4.51.bin

4.28.4.49 is the only one that seems to allow the bios flash sequence (light turns from amber to blue within 2-3 seconds), release button, camera reboots… then flashes the amber light forever. (well… i waited about 30 min before giving up.)

both 4.28.4.50 and 51 wouldn’t even get into the bios flash sequence, the light never turning blue while the button was pressed down.

My device is FCCID 2ANJHWYZEC2. I’ve tried multiple 32gb Fat32 formatted cards. I’m hoping to use RTSP, but have never seen it working since I can’t flash the firmware to a different version. Thanks for any help you might be able to provide.

We didn’t intentionally introduce any delay. It is likely due to processing and transmission time.

We updated RTSP due to two reasons:

  1. We improved security on the camera which contained changes we fixed for v2 and Pan regular version
  2. There was some hardware change on the recent v2 cameras. We updated the RTSP firmware to be compatible with the new hardware.

Thank you and glad to know it is working better for you now.

This is weird. Does it work if you try to flash with regular v2 firmware from https://wyzelabs.zendesk.com/hc/en-us/articles/360024852172? I would like to confirm that you have renamed the file to ‘demo.bin’ before the flash. Yours seems to be a generic flashing issue rather than RTSP specific issue.

Thank you very much

In the past I tried to flash my cameras with different SD cards, none worked, I tried different OS built-in sd card formatters. I read this thread here Unable to upgrade to the RTSP firmware.

I found out using the official sdcard formatter fixed my problem

I think it would be good if Wyze recommended in their articles using the official sdcard formatter for flashing the cameras. It would save people a lot of frustration.