MicroSD continues recording: MP4 timestamp is out of sync compared to onscreen timestamp watermark

Can someone help me understand why file timestamp is out of sync compared to onscreen timestamp watermark?
00.MP4 file was created on 1/11/2019 4 AM and onscreen timestamp (e.g. then footage was recorded) is 1/10/2019 8 PM. See screenshot below. Thanks.

2 Likes

I saw this happening to but after the lateste update it was fixed for me.

I’m running 4.9.3.64 firmware. Time only syncs when a file is shared (e.g. uploaded to iCloud, OneDrive, etc.) . When files accessed directly from MicroSD, time isn’t synced. It’s PST (my time) + 8 hours ahead. This bug could affect new features in development on the roadmap, like Network Attached Storage (NAS) and Access to SD card via network path

1 Like

I’m having the same problem: The timestamp on the video is correct, but the filename date/time is exactly 8 hours ahead. At least it’s consistent- but this will make it hard to locate a clip when I need to pull the Micro SD card and look through the files from there. I used an Android tablet, then a Windows 10 PC, to play back the Micro SD card. Same result on both devices. (The timeline index in the Wyze Android App is correct.)

I am not sure, mine changed date modified to when I put SD card in PC. :thinking:

The timestamps on the file metadata on the camera are in UTC time. The time displayed on the watermark is local sync’d time. The folder structure on the SD card is also in local time.

Therefore, @gxgolden, I can conclude that your in the PST time zone.

You are correct that I’m in the PST time zone. I suggest that the app should allow a setting for the user’s time zone, no? I have not seen that option.

I don’t think the file timestamps are going to change. But if you want to vote for the time sync to work by setting the user time zone, instead of the current method of syncing to phone’s time, you can do so here:

In my case, it would be fine for the time sync to go by the USER’s time zone. And if it went by the PHONE’s time, that would work for me also (I do not travel often). Having the filename tied to UTC time just does not work for me. I wish there was a User Setting for this.

It’s not the file’s name that is UTC (since it’s only minutes). The folder structure (the hour folder) that the file resides in is in fact in local time. But the file timestamp is UTC and I believe there are technical reasons why this has to be this way. So if you are relying on the file timestamp, I’m afraid you’ll just have to remember to make the mental adjustment of subtracting the 8 hours.

1 Like

Loki, thanks for helping me understand this-- but I’m not sure I agree. Unfortunately the apps and the Operating Systems have a lot going on and sometimes these things get out of control. I will just keep an eye on it.