Microphone always on if speaker is on


#1

I am new to this camera, and so far like it a lot. I may be doing something wrong, and would like some insight.
In the iOS app on a V2 camera, when I tap the speaker to turn on sound, the microphone becomes active, meaning I can speak through the iPhone to the camera without tapping the mic. I know I can disable allowing WYZE to access the microphone, but this does not seem right.
A plus however…when I speak through the camera in this manner, I am much more intelligible than when I press & hold the mic icon.
Is this by intent?


#2

What version of the app and V2 firmware are you on?

It doesn’t sound like you’re doing anything wrong. The mic button is a momentary button which is supposed to stop the mic when you let go of it.

This may sound silly, but are you sure you hear your voice coming out of the camera and not the phone? Normally if you are very close to the camera and activate the microphone, there is a huge echo chamber effect as the sound bounces back and forth between the camera and phone.

If there is a glitch going on here, I’d suggest first disabling the mic for the Wyze app in iOS settings. Then delete the app from your phone and download a fresh copy from the App Store.

Let us know if that fixes it.


#3

Thanks Rick.

IRT your questions, the firmware is 4.9.2.52 and the app version is 1.5.65.

The camera is on my main level, directly underneath my loft office, so it is quite easy to discern that my voice is coming from the camera and not the iPhone speaker. There is no feedback.

As I mentioned in my OP, I’m aware that I can probably work around this by not allowing WYZE to access my microphone on the iPhone, but that isn’t the intent of the app.

This issue is replicable 100%, so I don’t consider it a glitch.

Now, having said that, I just disabled then re-enabled the microphone in iOS settings, and then spoke into the WYZE app not using the mic button, and as you surmised, my voice came back through the iPhone. It did not come through the camera as it did previously. Very strange. I’ll play around with this further and reply back if I can get it to behave as it did previously.