Micro SD cards not recognized

How long did it take for the replacement to be shipped ?

Only took a few days through Amazon.

I am having the same issue on multiple cameras. I now have 5 cards that I need to try to revive with some sort of formatting utility.

My question is this. One camera makes the ding dong sound when I put a new card in it, and one doesn’t. If the camera isn’t making the sound, is the camera itself most likely defective or keep trying different cards?

In my case, the cameras that would not make the ding-ding sound were defective.

First, format all cards with this utility:

Then try them all one by one in any other device, eg a PC
If they’re recognized in your computer but not the cameras (no ding-dong chime) then in all likeness those cameras are faulty.

I’m having the same issue and just setup the unit, going through similar troubleshooting steps, following the units initial upgrade to firmware version 4.9.4.108. None of my class 10 FAT32 formatted micro sd cards, 32 and 65 GB are being detected.

are you resolved yet? Today is day 10 of my ticket being open.

My replacement Wyze worked right away with same card that wasn’t working in first unit.

1 Like

Hi All - this is my 1st post and ironic my 1st issue is with the SD Card. I bought my 64GB SanDisk MicroSDXC UHS-1 card before I saw the recommendation of 34GB. I loaded the card and everything worked perfectly- I was playing around with features and of course wanted to see if I could format the card in the camera. I got a bunch of spinning wheels and failures to complete. At this point my card was no longer detected. I just formatted my card without any issue on my PC and inserted it back into the camera. It registered, I turned on the use local storage and again I am now in business. Thank you for posting the above issues as they appear to have helped me! For what its worth i wont be formatting my card in the camera anymore.

1 Like

One of my two new Wyze V2 cam cannot detect micro SD card (with new observation)

  1. bought two new Sandisk Ultra Class10 genuine (card:A, B)
  2. bought two new Wyze Cam V2 (cam:Y, Z)
  3. already have three micro Sandisk ultra and Extreme pro 32GB (card:C, D, E) used in existing IP camera, tablet, Gopro)
  4. Cam:Y, Z upgrade firmware 4.9.2.25 to latest 4.9.4.108
  5. Cam:Y work with all sets of my micro SD card (card:A, B, C, D, E)
  6. Cam:Z cannot detect (No SD card available) with all sets of my micro SD card.(card:A, B, C, D, E)
  7. First conclusion : all micro sd cards are not defective.
  8. I can downgrade CAM:Z firmware from 4.9.4.108 to 4.9.2.52, 4.9.2.42, 4.9.2.28
  9. In order to downgrade , I have downloaded firmware demo.zip(BIN) of each version and
    run the process to downgrade firmware which it need demo.bin into the root folder of a micro sd card.
  10. Second conclusion: WyzeCam V2 micro sd card is not defective too, because I can downgrade firmware via its micro sd card.
  11. I would recommend the Wyze Lab to fix this bug in hardware/firmware and/or Wyze application .

Welcome to the community, @tg2000! It looks like you spent a lot of time on this. That is aweseome!

However, Wyze devs and support don’t normally monitor this forum because it is a primarily a user to user community. If you would like them to see this information, and get a direct response, please file a Support Request. Depending on the nature of the problem, rather than use the website link, it is helpful to submit an App Log and/or a Firmware Log.

2 Likes

Wyze cam stopped recording to SD card (sandisk ultra plus 16gb). The card is almost full. I can reformat the card through the app, but the it remains full. I tried to reformat the card using my computer and card reader, but my reader isn’t recognizing the card. This happened about 6 months ago and I had to buy a new SD card. Now it is happening with the new SD card. Is this just a thing with Wyze cam?

Remember that the card will always appear full because it records over the oldest material while the latest is still on the card. Just review a time frame to see that it is, in fact, doing its job. Hope this helps.

2 Likes

Same here

Hi DreadPirateRush
Appreciate your advice. I will send them a request. But firmware log also need to be kept and pull out from micro SD Card too. Now I have a ticket no from the support team.
Thank you so much

Actually I have run many scenarios. I borrowed more android phones to reinstall the Wyze app from the clean device, Uinstall/reinstall app with delete working files in an internal storage. create new user account to simulate with the downgrade firmware. The result is still them same that during normal operation, WyzeCam V2 cannot detect the micro sd card, but downgrade firmware using micro SD card can be completed.

Had my first real ‘not recognize card’ problem. New V2 cam and new SanDisk 32 gb card .- same as all my other cams. Cam installs fine works great. Put in card, won’t recognize it.
My answer in the past has been to deep format card on a PC, reinstall, and it’s always solved the problem.
Not this go round.
Ran the entire gamut from restart,power cycle, change cards, reinstall cam, factory reset, reflash firmware - everything I could think of - to no avail.
Card worked fine in PC and another cam.
Then the obvious hit - use the Amazon solution. Went back the same day it arrived, replacement on the way.
Hate to do it, but…

2 Likes

Now I got an email inform that they have processed a replacement for an report about the no micro SD card. The company sent out a letter said “We made a mistake” .
If anyone has a problem about no SD card issue, check that your Wyze V2 is eligible for replacement .
https://replacement.wyzecam.com/

Sometimes your mobile devices or digital camera says no memory card is detected, even though the microSD card is inserted within it. Reasons That Can Make Micro SD Card Not Detected /Recognized
Card is corrupted. …
Micro SD card got infected with virus or malware.
Card contains lots of bad sectors in it.
Check out how to solve it: https://docsbay.net/how-to-repair-undetected-or-unrecognized-micro-sd-card

1 Like

SD card is not being read by cams, it shows card but will not format; out of my six cams, 3 cams are not reading SD card. The three cam’s have sd cards stuck at .54 gb and .55 gg. It’s very important that my cams record continously.