Micro SD cards not recognized

try a different card in the cameras and see if they read. if they do the problem is within the card somehow. now sure what it might be at this point. have you formatted it?

where did you get the card? directly from Wyze?

After initial testing (and satisfaction) with my first Cam Pan, I just received two new Cam Pans and two new V2 Cams and updated each to the latest firmware. I then installed brand new 32gb Class-10 SD cards in each camera. The Cam Pan’s recognized the new SD Cards and record to the cards perfectly, but neither of the V2 Cams would recognize their new SD Cards (although the same cards are recognizable, and work, in the Cam Pan’s and/or my PC.) I can remove the working cards from the Cam Pan’s and insert them in the V2’s and they are not recognized by the V2’s. I have tried everything conceivable but my new V2’s will not recognize “any” SD Cards (although those same cards have been confirmed working normally in the Cam Pan’s and other devices). I am disappointed because the V2’s are brand new. I ordered them because of the current sound detection issue with all of my Cam Pan’s.

I am out of ideas. Does anyone have any suggestions, or should I just request an RMA?

1 Like

I am in the same exact situation except I ordered 4 new V2 cameras for my second order. All 4 do not recognize SD cards that work fine in other cameras from my first order. I spent a good hour with support today troubleshooting with no good outcome. I had to send proof of my purchase and am waiting for some sort of warranty process.

That is a shame. There is clearly something very wrong with SD card support… especially with the V2 cameras. BTW, how did you manage to connect with support and how long did it take?

1 Like

I have the same problem bought two cameras. Used wyze sd card that came with it but camera doesnt recognize it tried turning off resetting but nothing thought it was camera but it wasnt swapped sd cards and same problem with one sd card not recognizable and i just bought them any help out there

My two that failed were the Patriot 32 GB LX series, Class 10.

I’ve purchased v2 cams for a family member and went with Sandisk cards. I’ll see how those hold up, but I’m going to try the Samsung Pro Endurance to replace the ones that died in mine.

I just bought 4 new Wyze Cam v2s and 1 Wyze Cam Pan. I bought 5 brand new Kingston 32GB SDHC (Class 10) cards for these. I updated the firmware to v4.9.4.37 in 2 of the cams and installed one card in each of them. One cam recognizes the card right away and one does not recognize the card. Frustrated, I tried another brand new card in the same cam and it doesn’t recognize it, either. I then used the Sandisk formatting utility to re-rormat both of the cards that didn’t seem to work. Tried them both again in the same camera and it still does not work! Please help! I don’t have a lot of time to mess with this. Why doesn’t this just work?

1 Like

Same here.
3 out of 5 cams won’t recognize the memory cards - seems to be a bad batch of V2’s.
I suggest contacting the wyze Chat option for help,
They’ll send you replacements after the appropriate troubleshooting.

1 Like

Installed Samsung Pro Endurance 64GB cards in my V2 and Pan cameras 2 weeks ago. Both cards were recognised immediately and showing 59.9 GB free space available. Been doing continuous recording in SD mode and still have over 21GB free space available as of today. I’ll see how it does when it reaches its first over-write cycle in a few days. So far, however, no problems.

Just received my 2 Micro Center 32GB Class 10 Micro SDHC Flash Memory Card from Amazon and neither is being recognized in either of the 2 cams I received last week. Currently in the process of doing a full format of one of the cards to see if that helps. Frustrated!

1 Like

Still no problems with my Samsung Pro Endurance 64s. So far, still happy with the way they are working.

Sorry to hear and welcome to the club.
It’s advisable to re-format the cards with the following utility:


Upon the card insertion the cam should produce a double ding chime.
If it doesn’t and you can’t see it in the app then I’m afraid you’ve got a defective one.

Your cam is good.
The defective ones won’t recognize any SD cards from the get-go, no matter what…

defective card or defective cam?

there was a defective camera found by a user this week. it was missing a resistor. try another card, if it doesn’t work. I would start a ticket for a replacement.

2 Likes

Thanks for the suggestions. I’m hopeful this isn’t the case but so far it isn’t looking promising.

I wanted to give you guys an update on my V2 SD card issues (see my original post above). Turns out, both of the new V2’s I received were defective. They wouldn’t recognize any SD cards at all (no ding-ding sound). Wyze sent me two replacement V2’s (under warranty) and both replacements work perfectly (recognized the same cards that the defective wouldn’t recognize).

2 Likes

Thanks for the report.
It seems there was a defective batch of the V2’s
I haven’t seen anyone posting on the issue affecting the Pans.
I’ve also received replacements and they recognized the cards without a problem.

1 Like

I submitted a ticket about my 2 V2’s. No ding ding from either regardless of what sd card I use. We’ll see what happens.

1 Like

Wyze replaced the 2 defective cameras and the new ones seem to be working as described. It might just be me but I also feel like the picture is higher quality inn these 2 as well

1 Like