Lock keep wanting to recalibrate

Help! Bought the lock when it first launched. I have already tried changing out the batteries. I even bought 4 different brand of batteries but like clockwork it wants to recalibrate after 4-5 days. So I gave up and use it manually then 5 months has pass and thought why did I spend a $100 on a deadbolt lock that I would use manually. So I gave it another go, so i updated everything on Saturday and now its Wednesday and its asking to recalibrate again!!! What am I doing wrong? Is there a tip or trick to this lock?

@nerdypickle Welcome to the Wyze community! That’s certainly not the intended behavior.

I’ll tag @WyzeJonathan for you so they can assist you with this calibration issue.

Have you checked to see if there are any firmware upgrades?

What is your current lock firmware version?

The lock is up to date. I also deleted the device and reinstalled it but the problem still persists.

Can you confirm your lock firmware version? Thank you.

I have attached a screen shot of the device info

Thank you for attaching the screenshot. You are on the latest lock firmware which should fix the constant calibration issue.

Let me reach out to our CS team to offer a replacement for you. What is your order number and email for contact?

Please private message me those information.

Thank you and I apologize for the experience.

I’m sorry, I dont know what my order number is, but my contact email address is [Mod Edit]

Moderator Note: Personal information has been manually removed from this post. Such information often gets included inadvertently in an email signature block when replying by email. The forum software attempts to automatically remove email signatures but it is not always successful. When replying to the forum by email, it is best to remove the signature block yourself before sending.

I’ve had the exact same issue from day 1. I’m running the latest firmware, and every 3-4 days it wants to be recalibrated. I’ve also noticed that it doesn’t attempt to automatically lock or unlock anymore. I’ve got it set up on our outer security door, so at least I know that the main door of the house will be lock even if the outer door isn’t.

About a week or so ago I noticed my Wyze lock was not auto locking consistently. Now, just about every time I go to the lock within the app it complains that I need to recalibrate it. Which I’ve done, but still the auto-lock feature is sporadic as best. I have set it to auto-lock after 5 minutes, but now, sometimes it locks within a minute, sometimes (most of the times) not at all. The other day I checked the app and the lock was off line. I had to pull the batteries out and back in to get it to come on line again. While the batteries aren’t new, the app says they are at 41%, and based on my battery tester, they are all fine.

I am running 2.1.22 of the firmware. Any suggestions on how to resolve this will be greatly appreciated.

I just bought wyze lock on Amazon Canada and have to recalibrate couple times a day. Very frustrating.