Keeping Android viewer connected

Hello all. I seem to be bedeviled by the dropouts and shutoffs of 2 Android phones used here as WyzeCam viewers. I hope someone has suggestions.
We are using an LG Stylo4 (LM-Q710MS) downstairs, and an LG XCharge (LG-M322) upstairs.
WiFi courtesy of a Netgear R7000, about one foot away from the router.
The ONLY app running on both is the Wyze app; the cam is currently a single V2 above the front door.
Both phones seem to quit or go to sleep randomly.
Sometimes I have to reconnect WiFi; sometimes just restart the Wyze app.
What I need is advice on forcing these phones to stay awake, connected, with Wyze app running.

Android has a setting to keep WiFi on during sleep, check if your phones have this turned off.

Wi-Fi -> Advanced -> Keep Wi-Fi on during sleep .

Thanks – but I don’t want them to sleep, either ???

Let me explain.

Android maximizes battery. It puts apps that aren’t active to sleep. You can’t change this behavior. What you can change is to stop it from putting the WiFi component to sleep. You do this by setting this option to on.

If left off, then WiFi gets disconnected after a while. Then your phones have to reconnect to the cameras each time.

It uses more battery for sure, but the alternative is what you’re experiencing.

Edit – this assumes that your phones are using WiFi when you experience problems. If not, then something else is the problem.

1 Like

Looks to me like Wi Fi Power Saving mode needs to be off like this , in android v9

Android v 6
Keep Wi Fi on during sleep , Looks like it should be set to , Always

Thanks for the suggestions.
Yes, we are using WiFi, and keeping the phones on their chargers.
We already had those settings on.
The XCharge runs on Android 7 – a bit of deeper Googling points us to Settings / “Developer Options”/ “Stay Awake – keep awake while charging” or similar wording. We have set that, and time will tell.