iOS App Version 2.16.48 Released - 1/22/21

Good evening, forum folks!

iOS app version 2.16.48 is releasing now and fixes an issue that prevented setting up new Wyze Robot Vacuums (already paired devices were unaffected). Sorry about that and thanks for your patience to anyone that was impacted.

Read our Release Notes:

https://wyzelabs.zendesk.com/hc/en-us/articles/360024852172-Release-Notes

9 Likes

Sadly, this did not completely fix setup issues.
I now get past “request binding failed” error. But, the unit does not connect to the internet. Setup hangs on “Connecting, this may take a minute”. Twenty minutes later or so, get a “failed to connect error”.
I have v2.16.48 app, iOS14.3, factory reset vacuum “successfully” multiple times, reset router, turned off data, etc. etc. please help. (Oh yeah, I’m one of the lucky 11/20 orders that got “lost”)

This update did NOT fix the “request binding failed” error. My iOS Wyze app is up to date yet I’m still having the issue. :sob:

I ended up having to sign out of the app, not just redownload it (iOS auto logged me back in). Once I signed out (and reset my password…) it started working, no more request binding failed issue or Failed to update device list (error code 2001)

Thanks
Didn’t work for me. I have even deleted the app and redownloaded. To no avail. I no longer get “request binding failed”. But, it never connects the vacuum to my network. You select the Wyze vacuum network. It connects. Then, my device does reconnect to my network after a short time, but the device does not complete the “connection process”. It just hangs and ultimately times out with a “failed to connect - renewer your network password to retry”. Ends up in an infinite loop setup process…
Very disappointing.

Updated the Apple Wyze app and now when trying to launch app it immediately crashes.
So there goes my security for location.
I redownloaded the Wyze Apple app a couple times, same result.
Start it up… see Wyze loading screen for about half a second and then gone.

My main advice to any newer Wyze users is to NOT EVER update your app unless you run into issues or absolutely need to. There are far more negatives in these updates then positives, from my experience.

One version of the Android Wyze app a couple months ago used to create huge log files that eventually caused my Android app to shut down until I deleted those files manually.

I’ve experienced nothing but headaches.

I use both Apple and Android.
My android app is working fine.
Apple Wyze app useless.

1 hour ago I could view use my Apple Wyze app just fine… after update… garbage.
Also there is no way (or easy way for the inexperienced) to revert back to an older version of a Wyze app once you update… at least not anyway I know of.

Sometimes an app can be overdeveloped and be worked on by too many brains.

To be honest I’ve bought 4 Wyze cams.

You’d probably be better off investing in a close circuit security system.
Far less hassle, guaranteed,

If you’re looking for annoyances and headaches…

All the best.

The early days of WYZE where we all were filled with so much excitement, hope, and readiness to purchase as we were ardently proselytizing of there away from the insanely overpriced Arlo and equivalent options are long past, and WYZE has not changed its weak position on developing cross platform integration.

The latest generation of cameras and any newly releasing devices that do include HomeKit will not be purchased by Apple devotees any longer.

WYZE should be spent FERVENTLY addressing the tens of millions of iOS device owners that are rapidly being offered HomeKit integration with competitively priced options like Anker/Eufy, Meross and others.

The early days of WYZE where we all were filled with so much excitement, hope, and readiness to purchase as we were ardently proselytizing of there away from the insanely overpriced Arlo and equivalent options are long past, and WYZE has not changed its weak position on developing cross platform integration.

1 Like

This just happened to me, as well. I don’t know WHY I agreed to upload the newest app version, as I generally much more cautious about updating. Now, after uploading the newest version - 2.17.2.1 - I am getting the same exact actions as soul.shocker ;-{. I click on the Wyze icon to launch and the wyze screen comes up for a fraction of a second and CRASHES. I have deleted and redownloaded several times, thinking maybe just a bad upload… nope, same crashing happens. Now I have a v3 Cam I cannot use… this SUCKS!!!

WYZE team. please fix this right away. and in the meantime. please make a down level version available that we can use until you fix this. Why do we have cameras we cannot view? Why am I paying for Cam+ if I can’t use it? This was working perfectly, until I slipped and trusted that Wyze had put out a good update.

How does this get resolved?

any way to get a down rev version until Wyze figures this out?

I have purchased 5 Wyze cams, 1 Pan, 3 V2 and 1 V3; as well as the early sensor kits. seems iOS is an afterthought to the Wyze team. This may be the last nail in the coffin for me. Any other app I can use with my Wyze cams for iOS?