Integration with Alexa and Echo Show Not Showing Live Stream

I have Wyze Cameras V2 and V3. I successfully discover them in Alexa and able to enable with no problem. I even get person detection alerts. However I am unable to live stream to my Echo Show as it is unable to connect to camera. It works fine on my iPad and iPhone. I tried everything including enabling / disabling skill, deleting and adding device, rebooting cameras, rebooting echo, etc.; but nothing. Any ideas?

1 Like

I’m having the same issue. Don’t if it’s a problem with the Wyze app or with Alexa integration.

@jjerickson and @dg_marsh Welcome to the forum.

I use the Wyze cameras pretty heavily with a slew of Amazon “Show” devices. (Fire Sticks to the Echo Show 15)

I have tested all of my Wyze Cameras (v2, v3, Cam Pan V1 and V2, Wyze Cam Outdor,Video Doorbell, and Video Doorbell Pro)

Aside from the Video Doorbell and the Wyze Cam Outdoor. I was able to view my cameras at request on my Show devices.

The video doorbell is a known “not/sort of supported” device in the Camera family. The Wyze Cam Outdoor has not been working as it did in the past within the last 7-10 days.

In my experience generally this is an issue on the Amazon side of the house, but that is speculation at this point.

A few troubleshooting items I have done in the past as related to the V3 (some of which you have done) include.
Basic

  • Remove the Wyze Skill from Alexa and reenabling
  • Removing the Camera from Alexa and rediscover
  • Power Cycle of camera
  • Make sure Alexa, Wyze app, and Camera Firmware is up to date (If outdated, I would suggest a disable and re-enable of the Wyze skill in Alexa after update)

Intermediate

  • Rename the Camera

A little more painful

  • Delete the Wyze Device from Wyze, and Set the Wyze Device up again

Again, these are a few things that have worked for me in the past, but my v2s and V3s are working at this time.

Thanks. I’ve done all of these except delete camera from Wyze and set up again. I can try that and report results.