Instructions for Installing Wyze Cam on Synology Surveillance Station

Here’s how to install a Wyze Cam on a Synology NAS running Surveillance Station:

First follow these steps:

Then open your Synology Surveillance Station app
Click on the “IP Camera” app
Click “Add>Add Camera”
Select “Complete Setup”

In the “Add Camera Wizard”
Select the pulldown menu next to “Brand”
Select "[User Define]

Now enter the rtsp path as show on the rtsp settings page on your Wyze phone app
Or enter the rtsp path and add the port by inserting it after the IP address
example: rtsp://admin:password@192.168.1.10:554/live
Either should work.

Good luck!

8 Likes

Useful first post. Welcome to the community.

1 Like

Thanks for the detailed post. I have a Synology DS716+ NAS and will be trying your procedure in the near future.

It worked fine with my DS918+ so you shouldn’t have any problem at all.

One of the problems that Synology has is that they haven’t sufficiently invested in technical writers to document the features and procedures for using their NASs. This is a problem across the entire industry. It’s really a shame because in this case a good technical writer would’ve suggested to the engineers that they need to change the “[User Define]” field in the “Brand” menu to “RTSP” so consumers know how to setup RTSP cameras.

I love my Synology NASs but so many of their best features are undocumented and sometimes the user interfaces need just a little bit a tweaking as in this case.

2 Likes

Completely agree. I spent 35 years in IT before retirement and even I struggle with some of the nuances of my NAS (and DSM) … love it though. :wink:

Thank you for this!

Glad you found it useful. I had to watch quite a few foreign language YouTube video to discover the trick to installing Wyze cams on Synology boxes. No one should ever have do that again!

Hey Glowspud, thanks for posting the info. I’ve updated my cam with the RTSP firmware but my surveillance station still cannot find the camera. Camera functions correctly through the android/ios apps though.

Any ideas? Thank you

I think I had to reboot the Wyze a couple times before the NAS would recognize it.

If you really want to eliminate any network issues, I’d shutdown every device on the network and then start them up starting with the router, NAS, wifi APs, computers and then cameras.

Hope this helps.

Hi all,

Just want to ask before I decide to buy Wyze V2 cam to work together with Synology Surveillance Station SSS. Will this cam work with SSS detecting motion and triggers recording with the video eventually stored in the NAS?

Or it just shows up in the livecam of SSS as a video streaming without recording capability?

Thanks

Yes it works with motions triggers in Surveillance station.

I will say though that the Wyze RTSP stream is very choppy, slow, and basically not enjoyable to watch on SS. The audio is choppy as well.

It’s in sharp contrast to the video and audio in the Wyze app that looks great and loads fast. Might just be that the camera doesn’t have enough processing power?

I’ve tried running the stream on other programs and other Wyze cams with the same result. If anyone knows what I’m doing wrong, please let me know!

I’ve managed to get RTSP to work natively without a custom firmware for my Wyze Cam Pan (v1?) on firmware 4.29.4.40, I had the custom beta firmware previously but somehow it stopped working. I reset the camera and went through setup and came across the RTSP option (to my happy surprise!).

You had me excited there for a minute… But that’s not the stock firmware. That 4.29 prefix IS the RTSP version numbering. Below is a screenshot of the latest Pan version numbers.