I'm giving up on the wyze thermostat

I just thought Wyze support should know. I was an early adopter and I like it in theory but with it starting to get hot I’ve found the air conditioning not functioning properly. It will state it’s off but you can clearly hear the air conditioner running and the indoor temp will be 72 and the thermostat is set to 73. I don’t know why it won’t shut off. It does eventually but it might run in this off-state for a half-hour or more. Since we got the thermostat it’s worked fine for heat but our electric bill has gone up compared to last season for the air conditioning. I have all the same temps as the old thermostat and even synced the temp to the old thermostat in the Wyze settings but for some reason, The air conditioning is not as smart as the old thermostat and does odd things. Something this basic should not be so difficult. Also, the lack of implementation of an independent heat and cool cycle is a pain in the butt. Once it warmed up I had to totally redo my schedule rather than flip a switch like my old thermostat.

Oh well. Maybe they will make a much simpler thermostat in the future that operates like a old school thermostat with one heat schedule and one cool schedule and shuts off when it reaches 1 degree above or below the set temp. Seems simple right. Oh well. I’m done being a beta tester. If anyone wants to purchase my unit send me a message.

I’m having a similar problem. Worked fine for furnace but I’m so hot because the a/c isn’t working. I have it held on 70. My house is currently 77 and it’s not even on. I can cool my house overnight with windows open then watch my temp climb all day with messages like “7 hours x min to cool” There must be a an update or setting to fix this.