IFTTT related bug

android-and-ios
#1

Recently, I was wondering why IFTTT was no longer able to enable/disable motion events, per the related Wyze applets.

I looked into the settings for the two Wyze applets, that are related to enabling/disabling motion events, and discovered that the applet no longer knew about my 2 Wyze cameras!

I ended up having to remove the IFTTT-Wyze association, and then re-add the Wyze association, in order for my cameras to be detected again.

This is a bit annoying, as if I had gone away for a significant period of time, assuming that my Wyze cam had been properly enabled by the IFTTT applet, it would have notified me that the applet ran, but under the covers, it actually did NOT successfully activate the motion detection, due to it’s somehow having lost knowledge of what camera I had specified…

In other words, the IFTTT applets are flaky, and unreliable, at best. I actually don’t know if the bug is the fault of IFTTT, or the particular IFTTT Wyze applet that is being run.

This is why it’s probably a GOOD idea for Wyze to support geofencing enabling/disabling of motion events, per camera, natively within the Android/iOS Wyze app itself.

Additionally, add ability to reference count members of a household, via GPS tracking. Suppose two people live in a household. We should be able to configure it so that, if both people have left the house, enable motion events for camera A. When the number of people in the house > 0, automatically disable motion events for camera A.

1 Like
#2

Slightly related…

The Ambient Weather service on IFTTT has a trigger that goes off when the sensor has not reported for over 20 minutes.

Perhaps Wyze could add a similar trigger.

#3

I have 4 cams that I was using ifttt to enable/disable the motion detection. I too suddenly now have a problem with ifttt not recognizing my cameras .
Any idea why this has happened and how to get it repaired?

#4

Wyze has been made aware of the IFTTT issues, and is looking into it.

#5

If this happens to you, I found a temporary workaround.

In the IFTTT app, navigate to ‘My Applets’ -> Wyze. Tap the settings icon (gear icon) in the upper right corner of the screen and select the ‘Edit Connection’ option.

IFTTT will then take you to the Wyze login page. Login using your Wyze login credentials. You’ll be presented with a page giving IFTTT permission to use your Wyze devices. Click on ‘Accept’.

That should all you have to do, to get the IFTTT applets working again, at least until the next time they stop working…

Previously, I had removed the 3 Wyze applets I was using, disconnected the Wyze service, then reconnected the Wyze service, then re-added, and reconfigured, the 3 Wyze applets I had been using.

Obviously, the workaround I posted above is a lot less work!

One symptom of this bug is that if you check the settings for one of your enabled Wyze applets, for the ‘Which Device’ option, it’ll say something like ‘No devices found’, or words to that effect.

After you “fix” it (temporarily) using the above workaround, and then check the settings for one of your Wyze applets, your previously specified camera name should show up properly.

So, based on this workaround, it looks like either Wyze or IFTTT is automatically invalidating the Wyze-IFTTT authorization, after a certain (too short) period of time. Which is causing ALL of the Wyze camera related applets to stop working, since all camera name information becomes inaccessible to the Wyze applet(s).