How do you remove the Video Doorbell Pro?

I unscrewed the screw, and I’m trying to press down and up. I can’t get the doorbell to budge, and I’m afraid I’m going to break the mount if I push harder. Battery is about to die. Am I missing something?

Welcome to the forum @jonmark79.

Once the lock screw is loose, I give the doorbell a firm but controlled “rap/hit” with the palm of my hand at the bottom of the Doorbell holding the top with my other hand so it does not fall.

It does take a little force to disengage.

9 Likes

Excellent little video R.Good, and to the point.

2 Likes

Could you upload a video when you out ti back? I just got 2 doorbell pro and none of them fit correctly into the backplate. They never make the click sound!

Welcome to the forum @gonzaloagustins!

I will make an attach video as soon as I have some daylight. for sure.

A couple of questions first if you don’t mind

The back plate should have been on the Doorbell when you received the device so it should have a proper fit, but that’s not to say there couldn’t be some wonkiness going on.

How did you mount the back plate? Screws or the 3M tape? Can you post a picture of how you have it mounted?

Hi! I’ve tried the backplate in both of my Doorbell Pro cameras that I recevied yesterday, and it’s not fitting correctly. The pins will no go all the way inside of the whole, so the clicking plate never clicks on place.

With the plate mounted ( I am using the 3M backplate and wireless option in this video). I just line up the lower center tab, lean the doorbell back to the four corner tabs, a light lift up then push down.

I don’t necessarily hear a click but the device is secure,

Then tighten the bottom screw

Wired using the screw mounted plate, same process

Thanks for that! I also have experienced the same. While it is secure, it does not properly “click” in. I don’t think it will far off, however, someone could easily remove it. I think this is some kind of defect with the plate for sure, as I ordered two cameras and neither click in securely. There is clearly this click in function on the plate, and Waze had this in mind, however, it doesnt work! I wrote to them and explained this!

Just a thought…

If you have the screw mount plates installed makes sure the screws aren’t over tightened where it could cause the plate to bow even if just a little, cant tell you how many times that has gotten me in the past on some things.

And I do give the device a little rap on the top as well for good measure, kind of a reverse to the remove.

1 Like

Do you know what kind of screw driver is needed?

Screwdriver for the lock screw at the bottom?

It is a T8 screwdriver.

One of the poorest designs I have seen for a mounting plate. Everyone will eventually have a problem getting it out of the plate. I personally have to screw mine in since I only have stucco available to work with. In trying to install several of these I have some of these causes;

  • The base will rub against the power button cover stopping it from sliding up or down
  • If for some reason the screw is not in 100% it will cause the base not to slide properly
  • When using screws and not stretching the base correctly, It can bow causing issues this also applies to using the tape
  • Screw on the bottom too tight

Good luck with your mounting