Here is a Solution to video not playing back smoothly - guest network for Wyzecams 2.4Ghz only

Ok… I started a thread a while back about how I can’t play video back smoothly anymore on any of my Wyze cams (v1, v2 and v3 and Pan) through the app and it was looking like I was going to have to replace my expensive TP-Link Deco WiFi 6 routers in both locations with something even more expensive… but then a casual remark in someone’s comment in my previous thread about the fact that the Wyzecams operate on 2.4ghz only and that the router might be trying to send data to the cameras via the 5ghz band and that may be the cause of the problem.

So as a last resort I turned on Guest network on my router, made the guest network ONLY 2.4ghz (turning 5ghz off) and made the security WPA & WPA 2 which is what I believe the cameras operate on security-wise (not the updated security of WPA 3 etc.)

Then I connected my phone to the new 2.4ghz only guest network and then reset the cameras to connect them to the new guest network via the app and voila, the video is smooth to watch on all my cameras again! Just like the old days!!

I left everything else in my house on the original secure dual-band 2.4ghz & 5ghz network. Once I set the cameras to operate on the new guest network, I put my phone back to the original dual band network and to prevent my phone from connecting to the less powerful guest network on the iPhone I clicked the i next to the guest network name and turned off auto-join.

Everything operates perfectly now with the Wyze app, the video is smooth whether I watch from inside the house or out of the house.

The only difference is that if I want to add a Wyze cam I simply need to connect to the 2.4ghz guest network before adding the new cam. The app itself doesn’t care what network it is on after you’ve added the camera so all functionality then remains the same.

I just saved myself a lot of money and headache and this setup has been operating flawlessly for the past few days now.

In summary, if you can’t watch the video streams from your wyzecams on the app anymore because they are too slow or they just hang, your router might be to blame as it’s trying to send data to the 5ghz band of your dual band network and the wyzecams only operate in the 2.4ghz band. To solve this, set up a guest network that only operates on the 2.4ghz band and put your wyzecams on that network only and leave your dual band 2.4ghz & 5ghz network for all your other stuff.

Hope this helps others experiencing similar slow to nonexistent video playback.

2 Likes

Actually, a better solution is here, that I just posted:

Replace your router with a better model, and not TP-Link X60 Deco as they can’t stream Wyze cam video well at all despite being Wi-Fi 6.