Hardware decoder broken for V3 cams on Pixel 6

The 2.26.16 app will not connect to V3 cam streams on a Pixel 6 with hardware decoding enabled. The app hard crashes as well. This works on Pixel 2. Interestingly, you can still view them in grouped streams. Doesn’t affect V2 cams, outdoor cam, or even the V2 Pan.

3 Likes

Oh wow… my Pixel 6 pre-order delivery is this Friday. I’ll test and check if the issue can be reproduced then report here @WyzeTeam

Could more likely to be an Android 12 vs 11 issue, but I would have thought I would have heard about that too already.

Maybe it’s a combo of pixel 6 and Android 12. I tested it on pixel 3a on Android 12 but V3 streaming still worked Someone else mentioned pixel 6 and the same issue. Looks like @Seapup tested it on previous Android versions and it worked. You should submit a log any the crash of you haven’t already done so.

I submitted a log file.
Something off, hardware decoder has something to do with it, but a few times, even without HD on, still had no video, but app did not crash, I can see bitrate will bounce between 0 and 20kb and no image. Almost like 2 different issues, possibly.

1 Like

I tested this on my Pixel 6 running the latest Beta App 2.26.16. I can confirm it does crash. However, I have found that the Hardware Decoder is not really needed with the latest OS and the latest Phone models. It is a bug and should be corrected, but I have a question if you don’t mind. Why do you think you need to turn it on? I have issues with it on and have found things to be more stable with it off.

Just curious.

3 Likes

I’m curious what happens to you CPU and your battery life when you’re not taking advantage of the hardware acceleration.

I would rather have the dedicated video hardware handling video, instead of CPU’s. Dedicated hardware much more efficient., Battery frugal. Of course, any bugs all of that goes out window.

1 Like

I have found that not using the hardware decoder has made my entire experience when viewing the camera’s more stable across all camera’s. In addition, if you have HMS, I have found that I cannot add Camera’s to it and stream successfully with the Hardware Decoder turned on. When I turn it off, I can stream camera’s in HMS and from the main menu. In addition, I can stream if they are grouped as well.

My Observations and experience with my testing and past issues.

2 Likes

I will turn it off.
I watch the cameras a few minutes a day if that, won’t be big deal either way.
With all different SOC’s out here, not surprised doesn’t work right.

2 Likes

Same issue!

1 Like