Face Recognition use

It will still identify people and packages, etc. That helps cut way down on the “a car’s headlights just went by” motion notifications. It just won’t connect the person it sees to a specific family member.

I have not had any facial recognition on any V3 or the VDB. I am only getting Facial Recognition on my V2 Cam only.

1 Like

My V2 is in the garage mounted up higher up and facing down some. It picks up on Face Recognition, not 100% of the time, but it does.

My VDB is closer to face level and it has not picked up on face recognition, even when I am standing directly in front of it.

Not sure why it is not picking up on the face, figure it is still being worked out.

and Yes, I have Face selected as part of the AI. :slight_smile:

1 Like

I wonder if the doorbell has a slow roll out of that functionality. I had face recognition enabled for all my outdoor cams for a very long time before it started working. I know for some features Wyze has to whitelist your account before it starts working, even if you are in the beta program. The new rule engine comes to mind.

1 Like

I am not sure why Wyze would Whitelist me on this feature that they were asking Beta testers to join? If they are serious about moving this feature to general release. I would expect they would look forward to all input from the Beta Testers.

@WyzeShawn

Wanted to provide you some insight into issues I and others, like @carverofchoice , are having with Facial Recognition.

As indicated in the past Facial Recognition only works on my V2 camera’s. I did a test to show you the images and would be willing to test/try anything you would like me to.

In my Garage, I stood in front of the Camera, I was notified that Tony was in the garage, which was a great thing. The initial review of my events tab had my name with the event. I clicked on the event and the Face associated to it said Unknown, even though the event said Tony. I then assigned a Name to the Unknwon Face - mine. Now the Event Shows Tony but the Event Page shows an empty space now.

Here is the Event Page (I circled the Garage where there is no name now) - note above that are the others and they only say person

This is the Event for The Garage (Notice it Shows Tony, the header says motion)

Next I went outside to my Driveway Cam (v3), the VDB, and finally the Porch Camera (v3). All of which only indicated a Person was present not who.

Driveway v3 Camera

VDB

Porch v3 Camera

I know that it is being noted that the facial recognition works on the VDB and V3’s as well. But myself and others have not been able to get this to work.

Here is my facial page to show the faces my v2 has captured but nothing else has. I can click on each face so you can see all of the images for those faces if needed

What I am asking is the following:

  1. Is there something missing which is causing my VDB and V3’s to not pickup on Facial Recognition
  2. Is there potentially an update which I should apply but may not have yet
  3. What else can I try? I am willing to do what you need in order to determine if it is working correctly or if there is something that needs to be corrected.

Anything you can provide on this would be a great help.

Thanks

2 Likes

This is just me making a guess but I know when I was doing testing early on, slight angle differences would make a difference between catching the face and not. If you have the ability you might try placing a v2 and v3 side by side and see if they then both capture it.

2 Likes

Great Suggestion, I used to have a v3 next to the v2 and had the same result. I will definitely try this again and see. However, the vdb is a straight on shot, and I made sure I was looking directly into the camera. Did not even pick me up and add it to the faces page as an unknown.

Going to add it now… Will report back

1 Like

Ok so I did he test with a New V3 Camera just setup. It put me on the CamPlus Trial even though I am on the unlimited (99) CamPlus licenses. Don’t think this will cause an issue.

I have facial Recognition and Person selected for both. Garage is the V2 Camera Garage v3 is the v3 camera (guess I did not need to say that) :slight_smile:

I lined them up as close as I could to get the same angle. Eliminating as many variables as I could. Still does not work on the v3. This was a great suggestion and shows what I and others are experiencing.

Event Screen Showing the v2 indicated me and the v3 only said person

v2 Camera showing Face was recognized

v3 Camera only showing person

They definitely look like close to the same angle, at this point I think we can rule out environment and angle issues, hopefully this can help them get things working

1 Like

Trying some additional testing. Curious if it is working for you? If so, are you Android or iOS?

I honestly have not done much testing on it lately and my cams are at some extreme angles to get a facial detection. This weekend I may set some up and test again, I am on Android to answer your question though.

1 Like

Thanks, I just did another test but used my test iPhone and reset the vdb and the new Garage v3 camera CamPlus Settings.

Here is what I happened

I could not remove the trial license from my Android phone for the new v3 I was testing with. I ended up doing it from my iPhone and, while on the iPhone, I had to select the CamPlus options (Face and Person) again. I then went to the garage and tested (Nothing else changed), and the camera reported me on both camera’s. Figuring I was onto something, I decided to use the iPhone, removed the vdb from CamPlus (unassigned) backed out and then assigned it again. As with the Garage v3, I had to go into the vdb and setup the AI preferences. On this, I removed the vehicle only. Everything else is selected. I then went out to my Front Door and it recognized me. So it could be a bug with Android Devices. Not sure, but I am closer to the potential problem, I think. Here are some images:

Now to be fair, the second time I went into the garage neither Garage Camera identified me. Guess I am forgettable. :slight_smile: . Tomorrow I will test with the Driveway and Porch Cams to see if I have success with those as well.

I would like to figure this out so I can let Shawn know what I have found.

2 Likes

Looks like you are definitely getting good data to give Shawn. This could be a reason many are saying it does not work

3 Likes

Yea, here is something more interesting now. I went in to look at my events as I am getting person Alerts on my Driveway. I noticed that the Events which labeled me in them have now changed. So the issue may be bigger than expected.

This was the Front Door Image posted above (Android Device was used for this image):

This is what it is now on the Android Device

And this is what it is on the iOS device

This was the original Garage Image above (v2 and a v3 camera)

This is what it is now on my Android Device

And this is what it is on the iOS Device

Notice how the v2 (Labeled as Garage) maintained the “Tony” name. The v3 and vdb did not.

  • iOS now says motion and not person for the v3, Android says nothing (blanked out the name) for the v3.
  • iOS now says motion for the vdb andname blanked out for the v3

So this is a definite issue with the vdb and the v3 as it relates to the events storage and maintaining state or meta data.

3 Likes

Wyze is so lucky to have you test things like this. You are so great at testing and figuring out stuff and helping them improve stuff. If they don’t have you beta testing hardware, they really should just because of how thorough and insightful you are on bugs and such like this. I’m glad you’re here buddy. I’ve been trying to figure out for months why and how there is some kind of issue with V3’s and VDB Facial detection and you’re doing amazing at narrowing it down. Just proud of you buddy, happy we’re friends.

2 Likes

Thanks for the words and compliments. Feeling is mutual. You have to realize that you guys make me want to do this and continue. I truly feel like I am helping. But I have said this before and truly believe it, I pale in comparison to you and your ability to logically lay things out so that the masses can understand. I am getting better at that, thanks to both of you, but still have a ways to go. This is a team effort here, and we all contribute in many different ways and support each other. As with you, I am proud to call you all my friend.

2 Likes

@WyzeShawn @Jason21271 @carverofchoice

Still testing, but wanted to share my findings so far.

Last night I removed the Porch and Driveway Cam from CamPlus via the iPhone. I then added it back in, also via the iPhone, and set Facial on the camera’s. I now have the following camera’s, with facial recognition, and have been removed and added back via an iPhone.

  • Garage v2 camera
  • Garage v3 camera
  • Driveway v3 camera
  • Porch v3 camera
  • VDB

All seem to be reporting facial recognition now as you can see in the images.


Here is what I believe the problem could be

There may be a bug with the Android App when assigning AI preferences.

  1. Facial Recognition Menu choice on the Accounts page is indented where as on iOS it is not. Here is where I posted it: 2.24 Wyze App RC Test 8/25/2021 - #22 by spamoni4

  2. I tried removing the cameras from CamPlus and then adding them back in, via my Android device, with no luck. Did the same process with the iPhone, as stated in the beginning of this post, and it seems to be reporting on face now. I have 4 more cameras to do, and will try to do it later this afternoon - but I will utilize the Android device first to confirm my suspicions again. Unless Wyze found something and corrected it. :slight_smile:

  3. A new face added to the facial page allows you to set a name to it. This can be done via the event or in the facial recognition menu option. However, after about 2 minutes, iOS will simply switch the event to Motion and Android will blank out the name. Please note, I did the name setting on the Android device not the iPhone, so I believe it is related to the Android as well and the saving of the Meta Data.

I know I need to do more testing, but it is becoming apparent that it may be related to Android and not iOS. It could be related to how the Meta Data is being stored or sent for storage. Speculation on the Meta Data. However, it is a bit strange that the issues only occur when I use the Android Phone to setup the AI preferences as well as assigning a name.

More to come later…

2 Likes

…Here is the update
So I did more testing today and I have had success all around with my Cameras and Face Recognition.

  • Patio v3 Cam
  • Backyard v3 Cam
  • Side Gate v3 Cam
  • Driveway v3 Cam
  • Porch v3 Cam
  • VDB
  • Garage v2 Cam
  • Garage v3 Cam

In order for me to get Facial recognition on these Cameras I had to dp the following, not sure if it is a fluke, but it worked for me.

  1. I tried using Android to set the Facial Recognition for the Camera. Although it went through the process, it did not work for me. I had to remove CamPlus from the Camera and then add it back again. I had to do this from my iPhone. Once I did this, I was able to get Facial Recognition to work.

  2. I added Facial Recognition to the Backyard Camera from the Android Phone. It did pick up my face and report it back to me. However, I am not sure if I added CamPlus via the iPhone as I was having issues with one of the Beta releases and accessing CamPlus from the Phone. I ended up using the iPhone to setup items for CamPlus. This may have been one of those Camera’s.

  3. I used the iPhone to remove and add CamPlus back to my Side Gate Camera and when I walked by, it recognized me.

  4. @Jason21271 is correct, angle and placement makes a difference when detecting the face, My garage Cameras are about 7 feet off the ground and it has not issues recognizing me. But others placed higher needs me to look at it for recognition.

Basically, I have had 100% success when setting up CamPlus via an iPhone. Seems like the best thing to do, if you are having issues, is to remove CamPlus from your Cameras and then add it back again after backing out of the CamPlus area. I am even getting consistent package notifications which were sporadic before, if at all. Using the Android Device was also successful, but primarily for the v2 Camera.

In addition, when I worked with the Unknown faces on an Android Device, it was hit or miss on how it would behave. Most of the time, My Name would disappear on Android and in iOS it would switch to Motion. When I manipulated Unknown faces via iOS, I did not experience this issue,

All this to say, it appears the issues is primarily with Android and not as apparent when on an iOS device.

Here are a few pics to show it recognized me on my Cameras:

One Last Update

I added names to the following faces via the Android Device. Here is a sample of what happens to the Name followed by the event show unknown. Directly above are the same events appropriately labeled. However, after about 2 minutes or so, the name disappears and becomes unknown as shown below. The ones added via iOS persists without issues.

3 Likes

This is all amazing information and I commend how thorough and informative you testing and posts have been. Sounds like there are problems in Android and that is the only platform I currently have access to, but I am hoping I can do some testing this weekend.

3 Likes