Echo Show Times out with Wyze v3

Problem: Echo Show displays my v3 camera livestream perfectly fine, but disconnects after some time. The Echo show will show a “buffering” screen before disconnecting altogether and going to the Echo home screen. This is true of both the Echo Show (1st Gen) and the Echo Show 5 (2019). The time varies from a couple seconds to 10 minutes. Bandwidth is not an issue for either the camera or the echo shows (different rooms, mesh network reports high throughput to each device, not to mention I livestream PoE cameras at 4k to the echo devices without issue for much longer periods of time)

It seems there are some old posts which reference both a buffering issue, and a timeout issue, and I am wondering whether or not these apply in my situation. I upgraded to these cameras to replace my amazon cloud cams to use as baby monitors, but given the timeout, these will not work for my situation unless this is addressed.

I have been trying to find a solution here, but have not found any workaround. Could I get a straight answer from someone officially at Wyze?

1 Like

Don’t know the “official” story. What I have read here is that Amazon places a limit on this streaming (from non-Amazon cameras) that is usually but not always about 10 minutes. Some have had streams up much longer.

But you can NOT count on this. The “show me” feature is intended for short viewing unless you have an Amazon (e.g., Blink) camera. At least, that’s my understanding.

This is one reason I got a FireHD tablet instead. I use TinyCam or the regular Wyze app on it so there are no arbitrary limits.

Edit: but I see you don’t have this limit with other devices - what are they and how are you launching the stream to the Echo Shows?

I have several PoE Amcrest Cameras. I connect to them via RTSP urls, but the Wyze devices do not support this feature yet (per this link: https://wyzelabs.zendesk.com/hc/en-us/articles/360051619871-Does-the-v3-support-RTSP-)

I don’t know if that’s an amazon policy since my other cameras should not work in that case (Amcrest is not an Amazon brand). Would be interesting to see a comment from anyone working at Wyze on this topic - I have read several threads, but haven’t seen an official comment.

I’ll “echo” exactly the same thoughts. Echo Show always times out and I read it was designed that way. So I too bought firetablets for monitors using tinycam. It works very well and has some pretty cool features like changing cameras by swiping left or right, or just showing multiple cameras on one screen.

I asked on another post if anyone has had success with the new v3 cam on a firetablet. Whether I turn on 2FA or not, it just keeps asking for a code and it does not send a code to my iphone the way the v2 cameras do… Works fine on ios with the Wyze app.

I get the same timeout at about 10 minutes with FireStick. Also get the Buffering… message before it dies.

Ah, thanks, that’s very different then. How are you launching the URL on the Show?

Soon you will be able to get RTSP firmware so you’ll be able to use the V3s the same way.

The Amazon restrictions / timeout I mentioned apply only to Alexa "show me* commands via an Alexa skill like Wyze’s. I assume your access to the Amcrest RTSP stream starts differently.

Its the same functionality (“show me {name of device}”), but instead of the wyze skill, it is a 3rd party one for processing rtsp streams called “monocle”. If I could get rtsp firmware for my v3, that would solve the issue. I’ve seen some posts on it but everything says it is not a supported feature. Is this a confirmed feature on the roadmap?

Thanks for the info. I don’t have a reference handy but they have more or less promised RTSP for the V3 soon. They recently released a major RTSP update for the V2.

Also, Wyze just a few minutes ago revealed that as they deploy WebRTC it will eliminate the 10 minute timeout.