Doorbell connectivity & DHCP

I had several issues with my doorbell, mostly solved when it was replaced by Support. It is now working fine.

One issue that I came across was to do with IP address allocation and DHCP. I don’t know actually how this works so the following is a ‘best guess’ that seemed to solve my problem.

When the doorbell is installed it gets its local IP address via your phone from the router from a DHCP pool. Routers recycle that pool from time to time. What seemed to be happening was the router would release the IP address from the pool at the end of the lease (I think) expecting a renegociation by the clients and a reallocation. But the doorbell doesn’t renegociate. It keeps the original IP address. The router may then assign the same IP address to a different device - and then bad things happen.

I solved the issue by connecting the doorbell via a separate wireless AP with its own differently configured DHCP range so there aren’t potential conflicts - and there may be other ways.

Anyhoo, it worked for me.

Many routers will allow to to assign a static IP address based on the Mac address of the device. If the doorbell isn’t checking for a new assignment, this would need to be set up in the router prior to the first connection.

1 Like

Two notes:

  1. The phone has nothing to do with it. The IP lease takes place between the device (the doorbell) and the router.

  2. If what you report were true then there would be a serious defect in the way the doorbell handles DHCP. Routers give a specific lease time for an address and the device must renew it periodically.

I’m wondering how you determined the doorbell still had the old address. In my experience home DHCP leases are very stable and almost never change, even without “reservation” table settings.

1 Like

The doorbell connects to the network authenticating via the phone ap. The Device Info says what the IP address is. That was unchanging.

This isn’t a home router.

But, hey, what I did fixed my problem. The MAC address route would have too if I had thought of that, but there was a customer-use AP available and that route fixed it for me.