Delay to get event alerts

Turn off doze mode for specific apps

That is for Android 6.0, the issues I have are in 9.0 which lack those settings. The problem seemed to get big with 9.0 but some people say it happens in 8.1 also.

The only ‘fix’ I have found so far is to use a shell command to turn off deviceidle, but you have to do it at every reboot.