Connect Wyze Pan with Google WiFi (Mesh)

Hello,

I recently got the google WiFi (Mesh) and cannot connect Wyze Pan camera on the network. The google WiFi has auto frequency band 2.4 and 5Ghz

1 Like

At least some versions, the cameras will not connect to a dual frequency node.

Yes they will, you just have to add extra steps to connect. You have to disable 5G, connect the cameras, and then enable the 5G back.

1 Like

You might not even have to do that. I think if you connect to the 2.4ghz channel on the phone it uses that network. I connected the cameras using my old phone which only had 2.4ghz and the modem had both. When I got the new phones the cameras are still connected via the 2.4ghz and I am on the 5ghz with the phone now. So I think you should try that. Connect to the 2.4ghz channel then try the setup and then switch back and make it the primary or forget the 2.4 ghz on the phone. Im pretty sure that would work.

1 Like

I used the hotstop method. Turned on hotspot on my iPhone with the same name as my google WiFi name and was able to complete the set up on Wyze camera.

3 Likes

Thats really interesting that that worked. I wouldnt think it would authenticate very well unless your wifi is open and not secured. I seriously dont know how this was possible. Maybe to setup the cams for continuous recording. But have you tried to live view them yet?

I have a Google Mesh WiFi network. It has both 2.4 GHz and 5 GHz. It will connect to your devices with whichever gives the stronger and faster data transfer speed. I purchased the three pack unit from Amazon, but it is available from many sellers. I know Asus, Netgear, Linksys, Tenda, Jetstream, Samsung, Milo, TP-Link, Eero, Keewifi, and others offer a similar system.

We have a mix of 5 GHz and 2.4 GHz devices in our home. Mostly dual band 5 GHz and 2.4 GHz, but some 2.4 GHz devices such as smart plugs and a WiFi enabled thermostat. I began with my smart plugs and was having problems because the 5 GHz was so much faster and stronger in the locations that the smart plugs were placed. Google does not allow you to turn on or off the 5 GHz nor 2.4 GHz, or at least I was not able to find a way. I don’t know about the other systems.

I contacted Google and received some guidance, but not enough to get the smart plugs to connect. After some thought and experiments I did have success and want to share with the community what worked for me. I needed an old WiFi router, just a normal everyday router.

These are the steps that worked for me. They may work for you or you may need to try something somewhat different. I used an old TP-Link router as my second router.

  1. Be sure the power is off on the TP-Link router.

  2. Connect a data cable to one of the TP-Link yellow ports and computer.

  3. Power on the TP-Link router.

  4. Connect the computer to the TP-Link router at 192.168.0.1; username XXXX, password YYYY. Or go to tplinkwifi.net in a web browser to connect to the same configuration screen. Your address, username, and password will be different, search the web if you are trying to find the default username and password for your router.

  5. Power off all three Google WiFi network packs by unplugging them from the wall power.

  6. Go to the wireless screen on the router/computer. Change the name of the TP-Link 2.4 GHz to XXX and password to YYY. The Google and TP-Link systems MUST have the same name SSID, and password.

  7. On the wireless screen, turn off 5 GHz on the TP-Link router and save the settings.

  8. Be sure your smart phone sees XXX (SSID).

  9. Follow the normal Wyze setup process.

  10. Power off the TP-Link router.

  11. Power up all three Google WIFi network packs.

  12. Check to be sure everything is working.

This may look complicated, but it is not too hard. There a a couple important things to remember. The Google Mesh WiFi network SSID name and password MUST be the same as the TP-Link SSID network name and password. You will be setting up the Wyze Cam by fooling them when you switch routers. You must power off all the Google Mesh WiFi network packs and turn on the normal router network in the correct order, and then reverse the power process. I am saving my TP-Link router, powered off, to use whenever I get anything that runs on 2.4 GHz only and suggest you do so also.

I have had a problem using an AC extension cord. I know the Wyze power adapter is not polarized, but I have had luck turning the power adapter around if the camera will not connect.

I am not an IT guy, just a user. I welcome any constructive comments and suggestion. I’d like to know from others that have succeeded with a mesh network how they got their system running.

Good luck to you all!

John

3 Likes

Nicely done! :smiley:

Google WiFi does not give you the option of 2.4ghz or 5ghz. It creates one SSID and it will auto connect devices to either the 2.4ghz or 5ghz channel depending on the devices abilities. Also getting a different AP just to connect the camera is not a good solution.

MOD NOTE: Post edited to conform to the Community Guidelines

1 Like

I used the hotspot method mentioned above. In addition, I had to reset the Wyze cam using the button on the bottom. Hold it for 10 seconds, you’ll hear a bell, then it reads the QR code without a problem.

I am unable to get my new Wyze cam v2 working with Google Wifi. Yes, I’ve double checked the name and password. I always get the standard “failed to detect network name” (sic) message on initial setup.

To be clear, there is NOT a way in Google Wifi to toggle specific bands on and off.

I WAS able to complete setup by using the hotspot method – specifically turning off the google wifi and enabling my phone hotspot using my WAN SSID and password to simulate the home network. This was a pain, but it did work.

I know that I successfully simulated my WAN on my hotspot because I tested starting up my laptop and it connected to my phone seamlessly.

Unfortunately, I disable my hotspot and re-enable my WAN and the Wyze cam is unable to connect to the Google Wifi/WAN.

Help!

There is a simpler way if you understand how 5gz and 2.4ghz works. 5 GHz is fast but range is shorter. 2.4 GHz is slow but range is longer. So if you keep the Wyze Cam far away from the router it’ll automatically connect to 2.4ghz. in my case since I am using a mesh i turned off the nearest mesh and did the setup and it worked. (You can turn off mesh device from your phone app, turn it back on when your done).

2 Likes

This was great advice! Much easier than the hotspot method, which I tried for over an hour! I went to the room with the worst mesh connection from the primary unit, turned off the unit in this room, my wifi bar was at 2 out of 3, my 3 cams connected quickly!

So I know this is an older thread but I found this first when I was trying to find help with this same issue. Maybe my experience will help someone else. I have 5 wyze cams and 2 sensors. Moved from att uverse to google wifi two days ago, couldn’t get any of my wyze gear to connect to google wifi. I took a 100ft extension cord out to my yard to try and outrun the 5ghz wifi in case that was the issue, reset the wifi pucks several times, nothing worked. UNTIL, I found a thread talking about wyze stuff not liking wifi names that had spaces. I had named my google wifi the very original “Office Puck”. I changed it to omit the space to just “OfficePuck” and after that all my wyze gear connected almost instantly when I went through setup steps. Hope this helps someone!

Been reading these comments. I just stepped further away from the location of the router and it worked.