CloudFlare (1.1.1.1 DNS) blocking Wyze

I woke up this morning and went to open Wyze app and got a “network timed out” error. I turned off the wifi on the phone and was able to load the app and pull up my cameras. I was also unable to reach the Wyze fourms and support website. Restarted my router and I had no luck on my wifi even though internet was up and could surf the web. Called Wyze tech support and they told me a firewall was blocking me, I have no firewall in my router. I called my ISP and they also don’t use a firewall to block connections. I had them try the websites and they where having issues accessing the websites also. Found out the ISP routes through CloudFlare (1.1.1.1) DNS which I had also sent manually at some point in time on my router. I switched my DNS settings on my router to Google DNS and I no longer have issues. I hope this helps someone else.

17 Likes

Welcome to the community, @jedatkin. Excellent first post! :slight_smile:

2 Likes

And of course for those of us (including me) who are often technically challenged…

The DNS google uses is 8.8.8.8

Chas

6 Likes

And 8.8.4.4 for the backup.

5 Likes

I have been having problems connecting to my 2 Wyze cams remotely since Wednesday of last week. My home network uses the Cloudfire DNS so I wonder if changing my DNS wouldn’t fix my problem as well. To be clear I haven’t had any problems connecting locally, just over LTE. I have dealt with several Wyze Wizards and a couple of actual techs and no one can figure out why my cameras are failing randomly to connect throughout the day. After several RouteThis Help tests and factory resets I was about to give up on these and try another brand. I will switch my DNS and see if that helps. Good find.

With Firefox v74, there’s a new setting in General/Network Settings/Settings called “Enable DNS over HTTPS” and it’s clicked ON. This will use Cloudfire DNS servers instead of your own specified DNS servers. Disable this feature.

2 Likes

Did it help? I use 1.1.1.1 and have no issues connecting to Wyze services.

1 Like

I also had issues with CloudFlare DNS. The cameras still would work, but streaming would take longer and often was a jittery video feed. I switched to Google’s DNS for IPv4 and IPv6, and now my cameras work perfect. I hate using Google’s DNS since I don’t trust them, but looks like I got no choice now.

1 Like

There are plenty of other DNS services out there: OpenDNS, Quad9, etc. You could even use your ISP’s (but that’s probably worse than Google). :wink:

3 Likes

Anyone else start having issues with Pihole querying Cloudflare’s 1.1.1.1 ?

Nope. It’s been working great with my Wyze cams. OTOH, it gives me trouble with TheMovieDb.

Great, it’s quite useful for many, thanks for your sharing.

I use the cloudflare 1.1.1.1 DNS as my primary and OpenDNS 208.67.222.222 as my seconday DNS and I am NOT having any problems reaching/viewing my cameras. Hope this helps.

I use cloudflare as my primary DNS via pihole and I’m not having any issues with it either. Just to clarify, cloudflare’s public DNS (1.1.1.1) does NOT perform any DNS filtering so this should not be impacting any name resolutions with wyze products.

I’m not saying it wasn’t an issue in the OP’s setup, but it shouldn’t be.

3 Likes

I found a massive difference in connection to my cameras by changing from 1.1.1.1 to 4.4.4.4 on my DNS settings.

It used to take ages for my iPhone to connect until I changed the DNS servers. No other changes. Just that and now my cameras connect almost instantly.

Background. I’ve been in some sort of IT as a paid career for at least 28 years including working as a network engineer for an ISP so I know my stuff.

3 Likes

grc.com has an app called DNSBenchmark which will show available dns servers and which are the fastest. I have used it tor years and never had any problem.

5 Likes

Thanks for the response. TeaTV Shareit

This just happened to me. When I changed my DNS provider from cloudflare with DNSSEC enabled, to my ISP’s insecure DNS servers something close to 14 Wyze devices instantly became functional which were previously unreachable.

2 Likes

Very interesting observation!

I’m using 1.1.1.1 on a bunch of routers/devices, but have never created an account or dealt with the Cloudflare dashboard. So I presume this means I have not been using DNSSEC?

So I presume this means I have not been using DNSSEC?

I am running OpenWRT on my router and had it configured with the stubby package which (and I know just enough to be dangerous but not enough to be useful) uses DNSSEC and “Secure DNS” as alluded to on Cloudflare’s test site which I think is DNS over TLS (DoT). Just using 1.1.1.1 isn’t everything you can have configured in terms of secure DNS queries.

When I changed to just manually setting my WAN and WAN6 DNS servers to googles everything working again, but I don’t think I am using DoT in this setup. My next step to troubleshoot will be manually setting cloudflare’s without DoT and seeing if things continue to work. For now, I’ve been battling this for a week and I need some sleep!

1 Like