Can't view livestream from outside my home network

Hi community,

I have several Wyze cams outdoor.

I have been unable to connect to view live cameras from outside my home for a long time.
When I try to connect it gets stuck on “connecting camera by secure channel”.
I have run several test and I can confirm it is a Wyze issue. In fact a couple of friends have exactly the same problem.

If I am at home using the wi-fi connection I can view the cameras without any problems, but if I use the mobile 4g connection it does not connect.

Can anyone help me?

Thanks in advance.

Regards, Diego

What’s your home network wifi upload speeds?

1 Like

what are your mobile speeds on your phone?

and do you use any sort of VPN or router settings that might block an outside connection?

Can’t seem to find it immediately, but there is another post about this. Seems there is some issue in Android that is causing this and it was initiated in a recent update to the phones. I’ll try to do a better search later and see if I can find it.

Update: Other links

1 Like

Thanks WildBill.

I´ll check that post

HI Gemniii,

The upload speed of the wifi network is 12 Mbps. In my mobile data connection I have the same speed.

Hi Bam,

The speed on my mobile phone data connection is 12 Mbps upload and 60 Mbps download.

I’m not using any VPN, and I can confirm that the router settings are well configured.

I have the same problem with my WCO. If I drop the stream down to 360p it works. Both my V3 and Doorbell work fine though.

The router shouldn’t be an issue. Cameras initiate an outbound connection to the Wyze servers to establish a link with the phone. There is no attempt at any time to establish an inbound connection from the phone through the router. This is done specifically to avoid router and firewall issues by using an “established” connection which allows the two way communications. TeamViewer does the same thing to allow remote control of your home PC.

1 Like

very correct, but with the lower bandwidth needed for something like a wyzecam things like airtime fairness can be a pain. and although vpn’s are fairly widespread these days simple mis configuring could cause someone to throw a wrench into many settings. :slight_smile:

( my mom is still blown away I can use TeamViewer to fix her computer instead of driving an hour to be there in person…I love that program!)

I think it wasn’t that long ago someone was using UPnP or something similar and had something set wrong and missed what they had done ( easy enough) and had similar behavior. it may have been something missed with port forwarding. not completely sure now. I cant find the post. on the upside this does not sound like that.

@dnrodriguez what router are you using?

I’m using a Linksys EA 6900. No port forwarding configured.

1 Like

Did you have a chance to look at the other discussions I suggested? I didn’t read them thoroughly but I seem to remember there being an issue with the phones trying to use IP V6 rather than V4. You didn’t mention in any of your posts, do you have access to a different phone you could use as a test to see if it might be phone or OS specific?

1 Like

Hi community, apparently, lowering the quality of the cameras to 360p seems to have fixed the problem. I will continue testing and confirm in a few days.