Can't show my cameras on my Google Nest Hub

I’m trying to setup diffrent cameras from Wyze cam 2, Wyze cam 3 and Wyze cam pan v2. The cameras displays in the wyze app on my phone and i added the device to my google home app. They all show up in the google home app, but the camera will not display on the hub itself. When i ask assistant to show the camera, it replies the it can’t connect to Wyze home, and that i have to try later. Any ideas?

2 Likes

Did you add the “skill service” to Google assistant? That sounds like the problem. And sending the “service” to each device is necessary. In other words, have you added any other services to your hub, so you are familiar with what I am referring to?

No, i am not sure what you are reffering to. Can you please explain, or give me a link to something that explains what you mean?

No Camera is working anymore on any google display.
Just a black screen with Wyze in the middle

2 Likes

sorry, I’ve been gone. You must enable the skill that bridges Google devices to your devices. Skill is also what its called in Amazon Echo/Alexa slang
Search on Youtube for more info.
Here’s the link to Google Assistant’s skills. You need to browse through the categories and vendor choices until you find Wyze in this case. (Hint, hint, its under Smart home)

OK, so this issue with the Wyze Cams no long able to stream using a Google Hub seems to date back to over a year ago. However, I just bought my outdoor Wyze Cams directly from Wyze because of the claim it “works with google”. My Wyze switches work with google, but it said the CAMERAS work with Google. By definition, that means it shows live stream images. On the Google Home app, it sees the cams and lets me assign them to a home and a room, but when I click on them, it says to use a smartdisplay or chromecast device. Both my Google HUb and chromecast TV’s all do the same - Black screen with “WYZE-CAM” in white block letters. So, is Wyze now in the business of false advertising? I believe so.

5 Likes

Did you enable the Google Assistant’s Wyze service? Does not sound like it.

My wyze account is linked to my google home account. I see no where in the Wyze setup or Google home to “enable” Wyze services.

Please do a Google or YouTube search for how to, or read other posts in this same thread that help explain.

1 Like

As I said, my WYZE account is linked to my Google Home/Assistant. I can use Google Assitant/Home to operate my Wiyze switches. Google Home recognizes the Wyze cams, but it will not stream video. All google searches on the subject reach the same conclusion that WYZE does not work with Google Home.

okay, then it doesn’t.

I reported the issue to Wyze, they are investigating it.
I suggest to everyone who has this issue to report it to Wyze.
This way we have a bigger chance of it becoming a priority and a fix will be expedited.
In my case it works occasionally with a V3 camera. My other 3 (V2, Outdoor, Pan) camera’s are a no go.

1 Like

I reported the issue to Wyze, they are investigating it.
I suggest to everyone who has this issue to report it to Wyze.
This way we have a bigger chance of it becoming a priority and a fix will be expedited.
In my case it works occasionally with a V3 camera. My other 3 (V2, Outdoor, Pan) camera’s are a no go.

1 Like

Why are you being so condescending? This person seems to have the same problem I am.

The device is connected to my Google assistant and is listed in my home app. When Google assistant starts the Wyze stream to my chrome cast it stays on the Wyze logo and doesn’t produce the stream. Clearly this is a bigger issue than whatever you’re talking about.

3 Likes

I’m having the same issue in Chromecast, it used to work like 2 or 3 months ago and it stopped working a few weeks ago, everytime I try to show the camera it only appears a black screen and the wyze logo, I hope they fix asap

Same v3 issue here. Periodically works but most of the time just says “Camera feed not available” on my Nest Hub

can confirm my v3 cameras also stopped showing. my v2 cameras show up fine thoough

1 Like

Same here, v3 stopped working with wyze cam, we were using the setup as a baby monitor.
@wyze . This needs to be fixed ASAP, i got two new cameras and two nest hubs to use as baby displays…

1 Like

I am having the same issue. My V2 cams work but noy my V3 on my google nest hub. Cams work fine via app and google account is obviously linked to Wyze if the other cams work.

1 Like

I have the same issue. Cam v3. I have two Google/Nest hubs. I can neither pull mt Wyze Cam up on either,nor cast from any device. I reported this multiple times in the past, and each time got a “We’re working on it” or “Have you tried asking o the help forums?” type reply.

1 Like