Can't send 12 second video

I can’t share that 12 second video, I am getting a message - “can’t send video” . (I am trying to send it through WhatsApp Any ideas?

Hello @lbruce, try downloading the video then sending it directly from your camera roll.

Yes, I have tried that but I still get the same message.

I got it to work, l have a Galaxy s7, from the 12 second video, I hit download, find the video in the phones gallery, click on it, then click edit, and then click save. Then the video can be shared :slight_smile:

Same issue here. The video can’t be shared through any platform/messaging app at all. I’ve downloaded it, also edited as suggested above but still cannot send it. I’ve tried iMessage, text message, fb messenger, WeChat, and Instagram message, none of which worked. So weird! Still haven’t figured out a solution yet. I’m guessing maybe either the video file is encrypted or the format is not supported?

I just sent one through text message by hitting the share icon at the bottom of the event video

daqiancao, you didn’t say what type of video file you were trying to send. The original poster said they were trying to send a 12-second clip, which is typically 1-1.5 MB in size.

Size in mind, there are file size limits on almost all communication apps. Here is a very quick rundown of what I believe they are ATM:

Standard texting (MMS) is generally limited to 300KB-600KB depending on the version implemented. Your wireless carrier may also impose a limit. So even a 12-second clip could be a challenge here.

FB Messenger and WeChat have file limits of 25 MB, so you can probably send 12-second clips, but maybe not longer saved movies from your SD card.

WhatsApp has a limit of 16 MB.

Email is dependent on you and your destination’s servers, but typically is only 25 MB. And that’s after conversion for sending through a text-based system, which typically expands the size of the file. So you may only be able to send a 15 or 20 MB clip before conversion.

Instagram is more complicated. They limit you to 3-60 second clips but they also convert it to their technical preferences. They recommend less than 50 MB clips, but I’m sure that is the likely result after they are done tinkering with everything about it.

Like Instagram, iMessage is also more complicated. And to compound things, not well documented either. It has a large file limit when talking to other Apple devices (probably over 200MB), but a much smaller ~25MB or so limit when talking to non-Apple devices. Plus it tries to ‘fix’ your send to fit any constraints, including the tiny MMS limits above when talking to non-Apple devices. That means a 1080p video you share with a non-Apple user may come out the other side looking grainy, over compressed, and undersized. If it sends at all. I sent some clips to my sister who is on an Android, telling her “Look at the resolution of this little $25 camera!” and unbeknownst to me all she saw was a low-resolution grainy mess. Needless to say, she wasn’t impressed.

The way around all this is to send a link to services like Google Drive, SendAnywhere, or WeTransfer. Then your limits go way up, say 10 GB or so!

31

This is the info for the file–it was 1.4MB. However, I managed to send an older 12-second clip from a few days ago and it went through without a problem. I wonder if it could be a syncing problem, that the new clip was not uploaded or problem with server? – which still doesn’t explain why I couldn’t send the downloaded file on my phone (or iPad) either.

I understand how it’s supposed to work, but for some reason it didn’t work for me. I’ve also tried the share icon. Maybe it was just a corrupted file in this case… anyway thanks for helping!

Tried to send to who? If a non-Apple user you are constrained by MMS. Even on 12-second clips sometimes Apple can compress to fit those constraints, sometimes it can’t.

And then there was me a couple days ago – no matter what, I couldn’t get a simple screen cap to go to my sister from iMessage to her on Android. I kept reducing the size until it practically disappeared, but the send kept failing. Next day I could send pics again, no problem. That I’d chalk that one up to a temporary iMessage server issue.

Tried sending to my girlfriend, and even myself. Email, phone number, iMessage, text message, you name it.
Still, server issue should not affect a file that’s been downloaded, so it probably was a corrupted file.

A server issue can still affect a file that has been downloaded. In this case your downloaded file has to go thru the iMessage servers. If they are not accepting multimedia files as was my case, then you can’t send. If your girlfriend is on Android, and Apple can’t compress to fit the MMS restrictions, then it can’t send.

I am a little surprised that you couldn’t get a 1.4 MB file out by any means, but I would expect if you could play the file than it wouldn’t be corrupted. I’d be VERY surprised if both of you were Apple users, you could view the video, and you couldn’t get iMessage to send it using their giant 200MB send capability between Apple users. But again if the iMessages servers aren’t accepting multimedia for a time then it might even be possible Apple-to-Apple.

When you tried to send to other Apple devices, did you try AirDrop? No limits there (except having enough space to receive it).

Yes she also had an iPhone. It was being sent from an iPhoneX to an iPhoneXS. (and yes I also tried to send it as a green text message, and yes we also restarted both devices + toggle airplane mode) I doubt it was Apple’s server problem since I could send other pictures and videos–larger ones too, so size definitely not the issue. Later I found out that I could also send a 12-second clip from earlier, so the file type should not be the issue either. I could even click the play button to view the video while in the iMessage interface, but it just wouldn’t send.

From all the ways I’ve tried, I think it’s safe to rule out the messaging platforms as the culprit. It probably was a corrupted file, but I’m not certain. Usually I can troubleshoot pretty easily but it was the first time I encountered something like this.

Anyway, thanks for the help!

ah and I was referring to the Wyze server managing the uploaded clips. I could send other photos and videos so iMessage’s server was definitely not the problem.

From some research I think it may be that the clips use an audio codec unsupported by whats app. saving and editing may work.