Can't find specified network

Hello all, I’m having a issue with my wyze cam v1. I recently changed internet providers and I kept the name and password the same as my last internet provider, but when I go to connect the cam using the qr code after a few seconds the lady says cant find specified network. I’ve checked the spelling as well as unplugged the device and replug it back and I get the same results. can Anybody help and big thanks in advance!!!:blush:

Welcome to the community, @barberboy. Changing your ISP shouldn’t cause this issue unless in the process you also swapped out your router (EX: rent or buy from ISP). If you own and maintain your own router, you shouldn’t have to change anything. Which of those applies?

1 Like

I got a new router with the new service

OK, so at this point we (the forum community) needs to know more information.

  • The ISP you switched to
  • The router and/or modem model they gave you
  • Does the router have one SSID for the 2.4Ghz and 5Ghz networks, or are they separate?

ok I switched to spectrum as my Isp the router i don’t see a name on it but the modem is a arris and there’s 2.4ghz and 5ghz on the back if the router

I have a similar issue and hope for a brilliant result.
My WYZE cam works great at home, but I want it at my mom’s office in case of another break-in.
We use ShawOpen at the office, which nearest hotspot is across the street, and works good with laptop and iphone.
WYZE cam verbally indicates “cannot find specified network name” during setup.
I have confirmed 2.4 GHz and WPA/WPA2 for the network with no splash page.
Curiously laptop indicates ShawOpen 3 is the name of the network after connected, while iPhone only shows ShawOpen.
I have tried the different names with WYZE cam with no success.
Any ideas? Thx :slight_smile:
Charles

The SSID is the name of the network(s) you connect devices to. Do you have more than one network on that router, or just one?

I’m new to this and 60% certain you wasn’t talking to me, but in the event you are I just have the one network

If you look to the right on a comment, if someone is replying to you, you’ll see your name there with an arrow next to it.

So, it sounds like you need to contact your ISPs support, and find a way either turn off the 5Ghz network in the router temporarily while setting up the cameras, or get them to help you setup a separate network that is 2.5Ghz only.

1 Like

I’ll be contacting my ISP today, thanks a ton!!

After contacting my Isp they was able to disable 5g for me and I was able to connect the cameras, after it was done i re enabled 5g and all is well, thanks for the help I was a skeptic but am convinced now!

1 Like

Awesome! Glad you got it sorted out. :slight_smile:

1 Like

ok so we don’t have a Total success yet, i was scanning my wifi and saw only 2g was available. i called spectrum and they screwed up something and have to send a technician out tomorrow to fix the 5g here at the shop, so Hopefully I’m still good with my cams tomorrow, I’ll keep you guys posted :sunglasses:

I had the same issue after getting my first wyze cam v2. I tried everything that I could think of. I checked to make sure that there were no spaces before or after network name, separating 2.4 and 5 ghz networks, restarting the router and everything else I can think of. Nothing worked. Eventually I was able to resolve the issue by removing an apostrophe and a dash that were part of the network name and the cam finally connected. No idea why this worked but the Wyze cam seemed to have trouble finding the network name with symbols in it. The Wyze support staff that I talked to said that this should not be happening so hopefully it will be fixed in later firmware but until then if you are having this issue try removing any symbols from SSID. Hope this helps anybody having the same issue as me

I just purchased the Wyze Cam Pan. My plan is to install it in my boat and connect to the Shaw Open network so I can monitor it from home. I cannot get the camera to connect to Shaw Open. Shaw’s public network does not require a password but instead uses the MAC address to confirm you are authorized and to make the secure connection. Unfortunately, it appears that the camera login script cannot handle this scenario. Would be great if Wyze could make this change.
I would expect that there are a lot of customers in western Canada that would use the cameras and other Wyze products if they could connect them to the ShawOpen network. (I am holding off purchasing the plug and other sensors until I can make the camera work)
I am looking for workarounds. The only one I can find (but have not tried yet) is to use a GL.iNet mini travel router. If anyone has suggestions on how to connect directly to ShawOpen or have a good workaround, I would like to hear from you. Thanks.

Hi Peter,

I still have the same challenge. Wyze support has suggested update flashing the firmware which I have not tried yet since I am moving. Please advise if you are able to get this to work :slight_smile:

Charles

I am already at the latest firmware update on the Camera and still does not work. I put in a support request today so hope Wyze will address the problem. I would think that there is a very large market of potential customers in western Canada that would want to use the products on Shaw Open. I am continuing to pursue this. Will keep you posted.

Ty :slight_smile:

Welcome to the community, @PeterC. There is a #wishlist topic on this. You can vote at the top-left of the topic, and also add comments to the discussion.

ShawOpen is a secured network. They just use the device’s MAC address to validate the connection. You only enter your ID and password the very first time you log in, or you can also enter a MAC address directly from home through a web page. My understanding is that Wyze did not consider this type of authentication when they deemed all passwordless networks insecure.
ShawOpen is HUGE in western Canada. There are over 100,000 hotspots. A lot of potential sales for Wyze products!
Yes, I am hoping Wyze will revise the login script and facilitate the connection to ShawOpen. I am getting quite a few people contacting me also looking for this solution.
Let’s hope this move up on Wyze’s priority list.