Can't Add Vacuum to App

I’ve also tried factory reset on the vacuum and still unable to add device.

I did, however, try to do initial set-up on app without turning off cellular data.

on my phone’s wifi screen, it says Internet may not be available.

on the wyze select your network screen, it’s got the wifi network name, I type my wifi password. it says “Request binding failed, please try again”

HELP! I definitely don’t want to re-install my wyze app. I have 7 cameras, of which 2 are mounted outside (love the wyze cam3!)

You don’t have to reinstall the cameras Shirley. They are saved in the cloud. Deleting and reinstalling the app won’t affect that :slight_smile:

Thanks hagorush, It’s good to know my cameras are configured on the cloud.

Do you think it’d be worthwhile to re-install the wyze app in order to add the vacuum?

It has worked for some people so I would say it is definitely worth a shot. It has not worked for a few of us though.

1 Like

Not sure what happened but the device is on my app now.

Only thing I did was remove the dustbin and washed it out as i was able to run the vacuum without the app.

After I placed the dustbin back, I looked at my app and i saw the vacuum was added as a device.

Did not need to re-install the app.

Wow, uh alright. Yaaaaay it’s been added LOL

Finally got mine working. Had to turn on location services all the time for the wyze app. It actually did a wonderful job!

1 Like

Yaaaay for sure. And it did a pretty good job with the mapping. Could use some improvement on the edges.

My dogs always bark when I take out the vacuum cleaner - even the Dyson stick. But not a peep out of them with this. :grinning:

1 Like

SO!! I have FINALLY got mine to work. The last person (nelson.david) reminded me to check my location services which were granted to the application. However Apple has two levels of access (location access being 1, and precise location access being the other). My phone by default granted only location (always) access to the device but did not grant it the precise one.

Thanks nelson.david for your post. Really helped me figure this one out.

I literally had the vacuum packed up with the RMA label on it.

Wyze, you all need to get some better documentation out there on this device. It will save a TON of frustration.

1 Like

hagosrush - yay for you too !

Sorry, I forgot to mention the Precise Location on the iPhone. I leave that on by default for certain apps so it was already on for me. I just had to change it from While Using the App to Always. Happy we are finally figuring this thing out!!!

Ah okay. I have mine ask me. Though I don’t really understand why the app needs your precise location to work. I’m sure that’s an Apple thing. Wonder if I can disable it now that it’s in there haha

Bam!! Thank you soon much! Reading through these posts I thought hey let me delete the app data and then login and wouldn’t you know there is my Vac!! Thanks everybody!! I got a working vac!!

Amazing. That seemed to have worked for some and happy it worked for you.

Got my first clean last night and mad, the floors look good haha. And then my children woke up…

Like you, uninstalling the app while I was in the “connecting” process and reinstalling it and then I had the vacuum listed finally.
My setup - Samsung Note 10+, separate 2.4Ghz network name on Frontier router, mobile data off. Tried Wyze app uninstall and reinstall, phone reboot, vacuum reset, but none of that worked. Also tried over 30 times varying things slightly and turning settings on, off, etc., but it would sit on the “connecting” screen for several minutes until it would fail. When pulling up the Wifi info, I was still connected to the Wyze vacuum. Seeing your post, I decided to get to the connecting screen and then just exit out of the app and uninstall it. Reinstalled and the vacuum was finally listed as a device. I then downloaded a firmware update and the vacuum is cleaning the house now.
I already have several Wyze Pan Cams, their scale, outdoor cam, and multiple lights. I never had any issues connecting like this. Wyze needs to investigate the issue immediately or they are going to see a lot of returns.
As for the vacuum, now that it’s connected, so far I really like it. It is on the standard suction mode and is running quieter than the Roomba it is replacing. It is also very organized with how it’s moving through the house instead of the random crap the Roomba did. It’s also not running into all the furniture. I saw others saying they were having a hard time getting the Wyze to get the first map of the house because it would get stuck and then they would move it which reset it. So far, none of that has happened, but it’s not done so we’ll see.
I know others are looking for solutions to connect to the vacuum. Try what I did because it worked for me.

Yes it has been doing a very good job cleaning the floors for me as well.

I only wish I could create “rooms” for it to clean as it has auto generated some and well, one “room” includes the kitchen, family area, dining, breakfast and living room lol. I tried creating some digital walls to clean one room but have not really thought about how to get it into the rooms to clean those without going over the entire floor.

hagosrush, You can split large rooms (or a large room that is really multiple rooms from the Map Editor, click on the large room and then “split”


Oh great! I was hoping there was something I missed.

Here is where I went:

  1. Wyze app
  2. Tapped on vacuum
  3. Selected room
  4. Don’t see split option

Am I in the wrong place or do I need to reset the map?

Tapped on Vaccum
Tapped on Gear Icon upper right corner
Tapped on Map Editor, last in list
Then select Room
Then Tap Split.

But I am on the Beta App so? Version 2.16.53


1 Like

Then that’s why. I don’t have that option in mine haha