Cannot find specified network name

I’ve noticed a bug during setup. Wyze Cam announces “cannot find specified network name” during setup only to complete a successful connection a few minutes later. It creates the impression that setup failed when it was in fact successful.

Issue has been present for a while now (4 weeks or so).

1 Like

Which camera (and firmware version) and app (OS version and app version) are you referring to? It is helpful when reporting a bug to provide as much information as possible. :slight_smile:

3 Likes

I too have been having this problem with a new Wyze cam, except it fails to connect, no matter how long I wait. When setting up, I have to manually type in the SSID but keep getting the “cannot find specified network name” response. I have three other cameras that have been up and running for several months. I was in contact with support, and after lots of trouble shooting, it was deemed defective and a replacement is on the way.

Sooo, just today, after getting back from vacation, I see one of the older cameras is offline. After deleting it and attempting to reconnect, I am getting the same error with that camera. Time after time, “cannot find specified network name”. I start to wonder if the apostrophe in my SSID might be causing a problem, even though the cameras in the past were set up without issue. The reason why I considered this is because it didn’t remember having to type the SSID in the past, so the name was a flag for me. I renamed my wifi network w/o the apostrophe, attempted to set up the camera, and boom, connected without a problem. Grabbed the “defective” camera, boom, connected without a problem.

I upgraded the firmware on both, hoping that might resolve the issue, but it did not. I changed the SSID name back with an apostrophe, and tried setting them up again and would get the name error again. Looks like you’ve got an apostrophe bug. So now my option is to change the SSID so all the cameras work, but will then need to reenter my somewhat long wifi password on all of my other devices in the house, which would be a bit of a pain.

I’m running ios 13 and the latest Wyze cam app.

Thank you for providing this info, @tt1. I will pass this bug on to Wyze. :slight_smile:

EDIT: I found this topic from over a year ago, so apparently someone else had the same issue.

2 Likes

Thanks @DreadPirateRush. Wish I knew if this was something they’re going to fix soon. If not, I’d start the process of renaming my networks and reconnecting all my WiFi devices. Hard to believe only two people have been affected by this in a year.

Yes, I’m wondering how many people are having problems with this and giving up because they think it’s not fixable. I think it’s only certain special characters that are a problem. I use hypens and underscores in my SSIDs.

Good point @DreadPirateRush. Maybe something to stress in setup instructions for the cams to head off down-the-road problems?

You can bet that anyone who knows SQL will alert to a problem with an apostrophe in a field. I have no idea if it is the problem in this case, but if it is, the program is vulnerable to an injection attack.