Cannot connect phone or other device to 2.4 GHz

I just bought my first cam but there is no easy way to connect my phone to 2.4 GHz channel on my router. My ISP told me I could setup another SSID on my router, but then my mesh network will no longer work. I could set it up temporarily, but then they said the Pods ‘might not’ work when I change it back. I fired up an old phone, but I need to install a SIM card to connect it - too much hassle and I’m not even sure it will work.
Android on my ZTE phone does not allow me to pick the WIFI frequency.
I found a promising solution using an app called WiFi Analyzer, followed all the steps. It’s supposed to allow you to pick a specific WiFi channel but my phone only picks up 5 GHz despite telling it to connect on 2.4.
I’m at the point of returning the camera. It all looks great until you bump into this huge complication. I was really hoping to plug it in and have it up and running with 15 minutes effort (not days of wasted time). I was not expecting the need to reconfigure my WiFi network just to connect the thing. Is there no smart solution to this???

Think of it like a car - some cars run on electricity and plug in, some on gasoline. If you buy one that runs only on electricity you can’t run it on gas.
Unless you are willing to go to the hassle of running 2.4GHz Wyze cams won’t work.

Before buying a car, I would be aware of the fuel constraint. In this case the complication of the network bandwidth is not obvious beforehand. Yeah, I know it’s in the fine print, but unless you’re a geek who tinkers with your wifi every week or so, it’s easy to miss the significance of the 2.4 GHz requirement.

I’d love to hear of any solutions?

There may be a band steering setting on the mesh system that’s forcing your phone to use 5GHz.

Is there no way to set up a separate SSID for the 2.4GHz network on your mesh system? If your router has a “Guest network” feature you may be able to set up a separate SSID just for the Wyze Cam that only operates at 2.4GHz. Separate SSIDs for 5GHz and 2.4GHz networks is really the best way to manage frequencies. For example I have two primary SSIDs, “(networkname)” and “(networkname)_5g”, and a third guest network SSID “(networkname)_IoT” where I point all my smart devices. It makes it easy to know which devices are connected to which frequency.

It may also help to know which router/mesh system you have if you don’t mind sharing.

1 Like

I’m definitely confused here. First, what network equipment doesn’t emit a 2.4 GHz network? I agree with thequietman44, please share the name of your system. That could get me back on track.

Second, you don’t need to connect your phone to the 2.4 GHz network. You need to connect the camera to it.

Take my case – I have a simple dual-band router. It automatically emits both 2.4 GHz and 5 GHz networks. They are the same network, just at 2 different access frequencies. So my phone connects at 5 GHz, and my cameras at 2.4 GHz.

When the camera app automatically filled in the name of the 5 GHz network my phone was using during camera setup, I simply changed it to the name of my 2.4 GHz network.

So the phone does not need to be on the 2.4 GHz network. The camera does. And all routers should provide 2.4 GHz automatically. So definitely confused here…

My ISP Bell Canada is the router provider - it is branded as Home Hub 3000. In my original q I said Bell (the ISP) told me that I can indeed setup a 2.4 GHz network, but my mesh network (also from Bell) will no longer work, and even if I do so temporarily, then switch it back, the mesh network might not work afterwards. This doesn’t make sense to me but if I try it and they are right, i’m in a deeper hole and more wasted time.
Yes, i am trying to connect my phone to 2.4 GHz (I believe the Wyze instructions tell us that). It’'s also clear that you just need 2.4 to set up the cam and afterwards it will connect to the 2.4 GHz all by itself, so yes i get that too. And yes, the router is dual band also in my original post. Also in my original post - I noted the phone is a ZTE and there’s no option on their Android to pick 2.4 GHz.

In my other reply - yes i can setup a separate ssid for 2.4, but my mesh will not work (per the ISP) and even if I set it up just to configure my cam, they told me the mesh might not work again after I switch it back to 5 GHz.

This seems way to complicated and time wasting. Any simple solutions? I’m really thinking to just return the cam if not.

From Bell’s website I see this feature: “Band steering - Your devices will continually be pushed to the frequency that provides the best connection.” That’s undoubtedly why you can force your phone to 2.4GHz. If you don’t want to mess with any WiFi settings you would need to run the Wyze app on an Android phone running Android 6 or earlier where you can disable the 5GHz band, or a phone/tablet that only has 2,4GHz WiFi (original Amazon Fire tablet, you also mentioned an older phone).

It seems very strange that a mesh system can’t cope with some simple config changes, but I’ve seen stranger behavior on ISP-provided equipment. I may have time later to do some research on that, but as you say it’s probably not a 15-minute setup.

2 Likes

Again, the phone doesn’t need to be on the 2.4 GHz network. The camera does. They are just two different ways to get to the same destination.

As to the craziness the ISP is telling them, hopefully someone personally familiar with the equipment will respond.

Instead of separating 2.4 and 5 on the router, how about temporarily just turning off 5GHz entirely during camera setup. Perhaps that can be done without messing up the mesh when it is restored.

3 Likes

Thank you - that solution worked. I just got off the phone with Bell and that’s the same solution the tech support agent suggested, and he did it for me while on the line. After the cam setup correctly, he switched me back to dual band, the camera is still connected and working fine (for at least 10 minutes now). And, the mesh did come back afterwards (and homed in on 5.0 GHz after a few minutes).

Now i can get back to setting up a timelapse video of my garden growing!

1 Like

The phone absolutely needs to be on the same wifi frequency as the cam in order to set it up in the first place. I know this for certain now because as soon as Bell got it right and the phone connected to 2.4 GHz, the setup worked on the first try (whereas it didn’t work at all when the phone was on 5 GHz). Now the cam is working, the network is back the way it was (dual band) and the cam connects without fuss to a 2.4 GHz channel as it’s designed. Appreciate your attempt to help, but everyone should be clear that in order to setup your cam, you need a phone connected to your WIFI net at 2.4 GHz. After setup, dual band will work just fine. In my case Bell just re-enabled the 5 GHz freq after the can setup.

I think it worked because the 5GHz band was off, not because the phone was on 2.4GHz.

I set up all 4 of my cams with my phone connected to my 5GHz network.

1 Like