Can Wyze take accountability for extremely delayed notifications?

Maybe this is just an android thing but it IS wide spread. I have RIng doorbell and Arlo, all motion notifications wake the device from a sleep and notify RIGHT AWAY no matter what.

Wyze alerts mostly only work once you manually open the screen or if you are already using the phone. There has been posts about this for months and months yet nothing. I even just tried the new firmware and WYze Beta app and still the same issue, even with the paid cloud storage service. This is a deal breaker and I will have to use my other cameras for motion alerts. Sigh. This is a wyze issue and not android 9 or 10 or 8 or 7 or 6 or 5

4 Likes

For $25?

2 Likes

Wyze cam notifications occur after a 12 second event has been uploaded to the cloud which is in contrast to notification upon initiation of an event. This is by design. That 12 seconds may become minutes depending on numerous factors such as throughput speed, network latency, cloud server status, etc. If you haven’t already done so, please vote on this Wishlist item to effect possible future change:

Immediate notification of event

I had the same problem until I changed system settings on my Samsung, Lenovo and HTC devices. In the name of saving battery power, some devices running later versions of Android put “unused” apps to sleep making them unable to receive and display/sound notifications. Users need to configure this function in system settings to allow the Wyze app to run in the background (i.e., prevent Android from putting the Wyze app to sleep). These settings are ususally under something along the lines of “App power management” in system settings > battery and/or Apps > Wyze > Battery > Allow background activity and/or Battery optimization.

3 Likes

I see that response a lot. I’ve used it myself.
That should be in a Wyze ad.
Here are our list of features:
A lot of them don’t work very well but, hey it’s $25. :slight_smile:

4 Likes

I think this is a problem in the wyze server infrastructure somewhere.
Many people have worked with wyze support on this issue for months it’s not solvable by Android device settings, also is not a home network issue

From my point of view, things don’t work because Wyze isn’t testing enough. Could be a lot of reason. Maybe they don’t have the manpower, maybe it’s something else. But what’s the point of adding new stuff if the existing features are getting worse and buggy?

As for the $25 comment, notice every time someone complains about missing features, they mention the Arlos? How about comparing apples with apples? I still have a few of my older D-link IP cameras. They cost more than double but the features set isn’t any better.

1 Like

We shouldn’t be comparing them with more expensive cameras but Wyze are the ones telling us their cameras will do the stuff. :slight_smile:
I think the cameras are great. The software isn’t great but I can live with it.
If/when I get tired of waiting for Wyze to catch up I’ll move to something else. For now they do what I need. I’m not pretending they are security cameras.

On this topic though, the alerts seem to be working fine for me. I use beta firmware/software on an Android 9.0 Samsung S8+.

Motion alerts from the camera are not immediate. They occur only after the video is uploaded. In practice, that usually means around 15-20 seconds after the motion began. If you need more immediate alerts, you can get the Wyze Sense kit and use the motion detector included with that.

2 Likes

I don’t know if this thread is still active but I’ll post anyway.

This is the important part that people here are missing: “Wyze alerts mostly only work once you manually open the screen or if you are already using the phone.” It’s not necessarily an issue with camera notifications, but also motion sensors. For example, there was motion on my porch at 5:06 this morning. I didn’t get the notification until I picked up my phone an hour later, which apparently woke it up in some sense. This happens a lot.

I have a Google Pixel 4 running Android 10. Battery optimization for the Wyze app is turned off and I allow it to use data and battery in the background.

1 Like

I also have a Pixel 4 and am experiencing the same issue you are indicating. I found the following video of a potential hack or process to assist in notifications as it is believed to be related to the Doze options, which Pixel removed from the settings area. The Video is here: https://www.youtube.com/watch?v=SB3-k-3Cem4&feature=youtu.be

I opened a ticket with Wyze and provided some other pieces of information as others have worked around this issue. As a side note: my iPhone does not experience any delays. It is only on the Android phone and when it is locked/idle for a period of time while not on a charger.

If on a charger or being used (Unlocked), I seem to get the notifications quickly.

1 Like

Thanks for the tip. I had battery optimization turned off for the Wyze app already, with no apparent effect on delayed notifications. My understanding, which could be wrong, is that battery optimization is effectively Android’s Doze mode. Now I’m going to turn off Adaptive Battery as well and see if that makes a difference. I’ll also test the notifications when the phone is on a charger. I hadn’t though of that.

I looks like the hack you referenced turns off Doze mode but it has to be reapplied after every reboot. And it’s a program for Windows, which I don’t use.

Thanks for contacting Wyze about this!

Yea - that is the downside. the Doze mode on the Pixel is a little different than battery optimization. Some other Android devices actually has a setting for it, I think it is called Keep Awake, Not sure of the name though. Hopefully it will get resolved. My phone is sitting on a charger and getting alerts as expected. My iPhone works no matter what, but I switched from iPhone to the Pixel - I like the device. I am considering getting a battery case to see if that will simulate it being on a charger and hence the notifications will still work.

I have an Arlo and Eufy cams, but am planning on switching to the Wyze External Cams when they come out. Hopefully it will be corrected by then. The Arlo and Eufy tends to work, not sure of the exact differences, I even compared the settings of the app, and they are the same.

Do sms messages wake your phone up immediately? If so there is sort of a workaround using IFTTT to text your phone when there is a wyze notification:

Thanks again. My wife has an iPhone and gets the Wyze notifications right away, like you said. Oh well.

Yes - SMS seems to work fine. That is a good suggestion using IFTTT, but would like to use wyze as it is supposed to be. :).

I will try IFTTT and Alexa to see what happens

1 Like

Funny you should suggest this, as I tried it over the weekend; i.e., using IFTTT to send an SMS when a motion sensor or contact sensor is triggered. I quick test showed that it does work. The disadvantages are that (1) I can’t take advantage of Wyze’s “rules” to only send notifications during certain hours, and (2) it’s the same alert sound as for all other SMS messages, of course. Neither of those are deal-breakers. I just wish the Wyze notifications worked correctly! Regarding the alert sound, I see that I could create an IFTTT applet to make a sound on the phone (like play a song) rather than send an SMS message, but I didn’t investigate it further.

1 Like

Just tried Alexa, same issue with the notifications - so its a no go for me.

However, I seem to be getting alerts about every 5 minutes when the Phone is idle / locked. still not ideal when the iPhone is almost immediate. Unlocked or awake, the Pixel Phone is on par with the iPhone if not bettter

I am testing the Beta App to see if it makes a difference, I informed Wyze that it did not seem to make a bug difference, still no alerts when locked. Or at least the alerts are about 5 minutes apart. A few times it took no longer than 10 minutes… but that was not the norm

I used IFTTTT to send a text message (SMS) to my phone. I did the test first thing in the morning before touching my phone. I had my wife open a door that has a contact sensor while I sat by the phone. I waited and waited. No Wyze notification or IFTTT text message until I picked up the phone. Very strange.

Interesting, I normally get my Text Messages. I did do a couple of setting s on the Pixel, may make a little difference:

  1. Made sure the Wyze app Battery Optimization is set to Not Optimized
  2. Adaptive Notifications, Set that to None
  3. Unrestricted Data allowed for the Wyze app
  4. WiFi control set to Allowed for the Wyze App

Then I enabled Developer Mode on the Phone. Checked the Standby App setting and noticed that it indicated that the Wyze App was exempted. This is supposed to mean that the Sleep / Doze should not affect the app because of the Exempt Indicator and the item 1 above.

But my alerts have gone from about an hour or so to roughly 5 minutes. Still not what I exepct. but better.

I may also try the IFTTT and ADB command (But hesitant to do the ADB command)

Oh Yea - the other thing I did was install the Beta to see if that helped. the Wyze Support sent me the link