Cameras won't connect after firmware update

Sorry to hear the trouble you are facing. Thanks for the info and I’ll hold off my update since my two Wyze cameras are working fine for now. I’m always afraid of upgrading any working devices as I’m not sure how much testing has been done prior to release the updates.

1 Like

I have the same problems been resetting my wyzecam for a few days now I’ve followed the technician instructions but still not connecting. It keeps saying (wyzecamv2) “the specified network name can not find.

What should we do? I’m still resetting till now like new cam but still not working. I deleted the app, download again, reset the wifi, forget the wifi, reset again, still no luck.

I find closer too the router it will connect. But if I put it back to where I’ve been using it, it won’t connect. The same is true for both of my cameras.

I’ve had this same issue after originally successfullly adding the v2 cam to app. ,
I was able to resolve it by flashing an older version of the firmware (4.9.3.64).

Once flashed, I was able to scan / find network / add to app.
Once added it prompted to update the firmware.(4.9.4.37)

Much Faster than an RMA…

Same Situation here. Upgraded my V2s to the latest firmware ( v4.9.4.108), and lost connectivity with the cameras. Manually copying over an older firmware version (v4.9.4.37) to the SD Cards and holding down the reset button for a few seconds while plugging them in resolved the issue.

It’s probably wise to skip the upgrade to 4.9.4.108, and instead wait till the next version.

Updated to Person Detection firmware and updated app. Worked great first 8 hours or so and now Cams (V2) won’t connect. Very dissapointing. Wyze you sounded great, but I guess this is a “get what you pay for” situation. If you can’t get basic connection and simple live view it’s not worth $5.00 And yes I did all the resets, power cycles, etc. And to reiterate, Cams worked pre firmware / app update and then only worked for about 8 hrs post update (no other changes). Too bad, was promising endeavor

Welcome to the community, @JGvegas. If your cameras weren’t going work due to the update, you most likely would have seen issues immediately. With that said, are you trying to connect over your WiFi, or outside your local network (work network, cell network, etc.)? Are you using a VPN on your phone? The reason I ask this is the error code you put in your other post indicates the app can’t setup a connection. It’s important you provide as many details as you can for the community to assist you. Please see this support article for the error codes.

Sorry for double post, one looked a bit older than the other so I took the chance of posting in both as both are relevant. I also understand the need to cover basics when trying to diagnose, but please show mutual respect. I agree “most likely” would not have worked immediately, but that was not the case. Now let me throw some questions at you. Why would the camera properly send motion detection alerts and post the clips but not connect live view? Usage has all been on home network via wifi connection android phone, no VPN. And too me the bigger question is what changed other than the obvious new firmware and updated app. Wyze would not be the first company to have a problem with a release (only considering possibilites, like you with your VPN question).

Livestreaming through the app uses different communication channels than the event notifications sent by the cameras. This means we need to focus on why the app on your phone is not setting up the initial connection with the camera for the live stream. Just out of curiousity, have you tried all of the troubleshooting steps on that page where the error codes were listed? It may be very helpful to Wyze for you to submit feedback with logs via the app. I would also recommend running the RouteThis Helps app mentioned on that page and attach the code created with the support request. As far as I know, you are the only one at this time reporting this as an issue. I’m not saying others are not experiencing it, just that I haven’t been seeing a wide-spread problem as of yet.

BTW, I’m not a Wyze employee. I’m just a user like you who volunteers to help out on the forum. :slight_smile:

I appreciate you reaching out. Yes I did contact support and sent them a log per the instructions.

I have been able to get Live View working again by

  1. Turning off power to cameras (unplug)

  2. Turning off my phone

  3. Turning off router (unplug)

  4. Turning router back on after 2 minutes

  5. Turning cameras power back on

  6. Turning phone back on

Live View now steady again. I have selected Person Detection again and hopefully things will remain stable.

The only two things I can think of that caused the problem;

  1. Doesn’t make sense but the only thing I changed in the app was the 360 to HD setting prior to Live View all of sudden not working anymore

  2. Perhaps there is something going on in the background with the Person Detection AI, because it worked for hours then all of a sudden Live View wouldn’t connect.

The power off / on of multiple devices would be very problematic for the typical consumer. So as Wyze tries to be widely accepted with the average consumer perhaps there can be a better, user friendly system reset “button” in the app if that is technically feasible.

Also if you have to unplug cameras to reset the system becomes useless when remote from the location of the cameras. I did read a suggestion on some sites that said get a wifi plug so in case you have to reset from remote you would have a fighting chance, but that certainly becomes a pain

Curious if the tech sees anything from the log

7941A3E0E2C34AB083ED52FEDF3855F1.png

Computer Guy here, wow, these are hard to connect. Been trying everything with my router…too bad this is not smoother. Read all the tips for ASUS router. After about 25 tries, about to give up. I have no clue what firmware is on the camera, just got it, has never connected.

By the way Person Detection works great for my use case which I think might be common situation. Camera pointing out front door (sitting inside side light window). Motion detection kept sending notifications when a car would pass by. I shrank down the detection zone which helped eliminate car passing notifications, but the Person Detection is much more desirable. Now I don’t get bothered by “car passing” notifictions, just people which is what I want! And of course Wyze was smart enough to allow both options.

Also by the way my initial connection setup went very smoothly. It was just a pain to reset when something went wrong for me. Fingers crossed things stay stable

Glad to hear Wyze support was able to help you resolve this! :slight_smile:

I too am experiencing an issue with the Wyze Cam v2 after the firmware update, however I got the update a couple days ago, and last night out of nowhere, i lost connection. I use the camera everyday for my children and have had it over a year with no issues what so ever. I also can normally fix an issue like this…

I have the wyze pan cam as well and all is fine with that camera, I also have another wifi camera and is working with no issues. Here is what I have done. After it saying internet connection issue on the app, I restarted both the camera and the router. So I deleted the camera and tried to set it up again, and now I am getting “cannot find specified network”. I have tried 2 different routers both being on 2.4ghz and no vpn here. I’ve uninstalled/reinstalled the app, and I am now trying to go back to a different firmware, however I may be confused on that. I put the 4.9.2.18 demo.bin on a sd card and put it in camera and held the button while plugging in power cord to try to do the firmware upgrade, It states that the light should turn solid blue however it does not and just says “ready to connect”. How do I know if I am successfully updating the firmware?

Any help would be nice.

i was having same problem after updating today. Here is what I did to fix it. I unplugged the wyze came and removed the sd card and put it in my computer. The computer said something about the SD card being currupted, and asked if i wanted to fix it and i clicked YES(but lost all footage on sd card)…after that, i put the sd card back into the wyze cam and plugged everything back in. Worked on the 1st try. no issues since.

1 Like

I’ve had the same issue. It first started after updating my cameras with Person Detection. One day my Pans were working the next day they were not. I tried everything except SD card because I wasn’t using the cards. I also tried a brand new V1 and I cannot connect these cameras. The rest of my camera network works, for now.

I submitted a ticket with support but have not heard back.

Even a V1 I get “cannot connect to network. Nothing that I know of has changed.

Okay guys I totally forgot to check my phone was connected to 5ghz. The new Xfinity router shows up as one address. Not split.

Anyways Jacque from Wyze support helped me.

All units are working.l now.

1 Like

I was having the same problem after the latest update in July. The camera would either get stuck on a day and not connect or just go offline and not be able to reconnect. After power cycling numerous times and uninstalling/reinstalling on my app, the tech guy I’ve been talking with via email suggested flashing the firmware. I flashed back to the April version and so far so good. It prompted me to update and I’m going to choose to wait until the next version so I don’t start having all the connection problems that came with the July update.