Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

Most common problems are

  • Suppressing extensions on the computer where you add the file to the SD card – so ‘demo_wcv3.bin’ is actually ‘demo_wcv3.bin.bin’
  • Not pressing the setup button properly – the water seal rubber cover must really be pressed – whether thumbnail or tool – until it ‘clicks’. And then you have to maintain that thru the power-up until the lights change.
  • Not using a 32 GB or smaller card

You should only need to load the file firmware. If it asks you to go further, that is the cloud – refuse.


I use a 8gig card
Dropped the demo file on the card.
I didn’t change the file name.

Put sdcard in camera
Hold the button in on camera and power up.

In half of second you will see blueish light.

If you look at the camera on a 45°
You can kinda make out purplish or whiteish color.

It’s definitely not bright purple.

Here is a pic of blue and the purple.
The blue and purple are so close in color.

Hold button untill the red light goes out.

got it fixed yesterday… was using a 64GB sd card. grab a 32GB and it worked no problem!


I just picked up a couple of the Wyze Cam V3 to test with my Blue Iris setups.

I got one camera working over RTSP as a test, but now I would like to have it ONLY running on my internal BI setup, not also brodcasting over the internet to the app. Is this possible?

I did try deleting the camera from the app, but it stopped working on BI and the red light on the cam started blinking. Had to set it up in the app again.

I don’t use RTSP or Blue Iris, but is it possible BI gets it’s stream from a Wyze login?

The RTSP login is different than the app/account login. I just shut off all recording and notification features in the app and let BI do all the work, including getting all my feeds on my phone as needed.

Some further reading seems to indicate that these cameras need internet access to intermittently “call home”, else they may stop working until “authenticated”???

Yes, but do your give BI your Wyze login info?

On the Wyze side of the fence there are protections requiring authorization to see the feed. Are these protections extended to BI I was wondering.

Nope, as I stated, RTSP login is separate.

Blue Iris is an independent camera server software and has all it’s own features and protections. All I want is to get the WYZE cams to function as a basic IP camera without needing any cloud connections

The better way to do it is to restrict access by the cam to the Internet at your router/firewall. When you do, the cam will drop off about every 3-5 minutes to try to make whatever connections it wants to their P2P network, time servers, et. al. The cam will come right back up in about 30-45 seconds or so and work fine other than that. Or you can put them in a guest network to segregate them and just let them out. If you want to use the AI-based person detection then you’ll need to let them out since that’s cloud-based.

You kind of need the cam in the app in order to access various settings since there’s no web interface otherwise but there’s no communication out over the net through the app as far as I know.

1 Like

Just FYI, I have ffmpeg working with 2 Wyze v3 RTSP cams:

Later I can try moving the YouTube service to my RPi, since it’s not doing any transcoding, and the Pi is perfectly capable of forwarding packets. like I’m doing with my Reolink BeeCam.

My current command on the Mini:

./ffmpeg -thread_queue_size 2048 -i 'rtsp://anonymous:password@' -vcodec copy -acodec copy -t 2:00:00 -f flv "rtmp://"

and my current command on the Pi:

./ffmpeg -re -thread_queue_size 512 -rtsp_transport tcp -i "rtsp://anonymous:password@" -f concat -safe 0 -i playlist.txt -vcodec copy -acodec copy -t 01:47:02 -f flv "rtmp://"

The playlist is for the music track, since my Reolink PTZ cam doesn’t have a mic, and YT requires a soundtrack.


Are you uploading 24/7 footage or just motion/audio detected clips?

I’m trying to stream 24/7, but I need to pause ffmpeg and restart the stream every 12 hours or else YouTube won’t archive it properly. So there’s so manually fiddling required every day until I figure out how to automate it.

I’m simultaneously recording 24/7 to my BlueIris computer, because BI has much more sophisticated motion alerts than the internal WyzeCam detection, and I don’t want to pay for CamPlus.

I just set up the WyzeCam ffmpeg/YouTube stream last night, so I don’t have a lot of data yet, but it ran for 12 hours overnight, and it’s been running for 3 hours this morning without a hitch.

1 Like

I now have five Wyze v3 cameras, seven other ethernet cameras, and Blueiris 5. I had a lot of disconnects, pretty much solid. Here is what fixed it for me. First, I moved the Wyze cameras to SD (720p) instead of HD (1080p). This cut the data flow by more than half. I had to restart each camera (unplug, wait 15 seconds, plug back in) and reboot my dream machine for this to start working. Just reducing the data flow fixed four of the five cameras, but the fifth continued to lose the connection. So I reinstalled 4.061 on it. That seems to have completely fixed the problem – while I lose the connection occasionally, it isn for less than 10 seconds before it reconnects.

Hi Gang, sure is one long thread! I’m sorta lost though.

Currently (27 March 2022) can we set up a Wyze Cam 3 with RTSP without going through the Wyze servers- i.e. just point to port 554 on the local IP address? And not have it drop for 30 seconds every few minutes while it tries to phone home? Thanks!

RTSP firmware still needs the servers at startup/powerup. Once running, you can connect directly to the camera’s IP using the RTSP port.


.but it will still try to phone home and “stall” during that process.

so… nope,

1 Like

u can actually use the lowest setting in the wyze app, 360p, blueiris still use the highest bitrate as shown in the camera settings tab

u state setting up the camera, setting up how?

Did you check the very first post?