Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

How do other camera manufacturers handle video when the “power of the camera is turned off” ?

I think what he means is RTSP interruptions happen when the camera is powered off then on without an internet connection. I would love to hear of any alternative cameras that can work without a persistent internet connection, After a bunch of trial and error the best I can do with the Wyze V3 is 3 mins of uninterrupted stream before a failed API heartbeat or whatever causes the cam to attempt to reconnect to wifi and drop the stream. For my usecase this is only “okay” since at least I can get a repeated interval of 3 minute chunks of real time video feed followed by about 30s of nothing, but it’s annoying to say the least.

1 Like

I totally agree with you. An RTSP camera is supposed to work 24/24 event without internet. This v3 RTSP camera will not work properly after a restart (or a power failure) if there is no internet access. It will lose connection (freeze image) every 3 minutes or so. Don’t use it as a security camera, you will be disappointed.


Hello @macster2075, All of the Amcrest Camera’s I have purchased support RTSP, the only issue I had with the Amcrest Camera’s is if I wanted to used use them with my Amazon Echo, Amcrest requires a monthly subscription to allow that to occur.

All of the Amcrest camera’s I referenced are being used with Blue Iris via RTSP.


1 Like

Search for Monocle Gateway. It’s a bit to set up but you can use that to integrate the Amcrest (or pretty much any RTSP cam including the Wyze) with the Echo without any subscription. You can run the gateway on your BI server. BI had a direct link with Alexa at one point but don’t think that works now after some changes on Amazon’s side.

1 Like

Man, I really wish I had found out (seen this post) about the constant freezing after reboot without internet.

The main reason I picked up the camera is that it has great night vision and is RTSP so I could isolate it. I hate exposing any indoor cameras to eternally hosted services.

Why can’t this be a permanent featured added to all cameras? This would greatly expand the use of Wyze cameras with other brands and apps. Now Unifi Protect will allow you to add RTSP camera to the system. This would be a huge step for Wyze cameras just to allow it as a feature.

I hate that too. Now let’s hope that Wyze provide an RTSP update to solve this issue. After all, a beta firmware is supposed to be followed by a stable released firmware.
But I’m wondering if Wyze is considering this an issue since, with this firmware, they can track every RTSP camera in the field…maybe that’s their purpose?
This RTSP camera cannot be considered a security camera if there is a possibility that it keeps disconnecting after a reboot.

The Wyze Cam v2 RTSP firmware never went out of beta but it also did not contain all the features of the main firmware due to hardware limitations. However the v2 RTSP firmware worked fine fully blocked from the internet.

Would be nice if this was just an advanced setting in normal firmware, but it really needs to work fully offline.

Hold on, are you sure about that? Everything I’ve read in the forum indicates otherwise (that after about 24 hours without Internet, or deprived of Internet at startup, the V2 RTSP becomes useless).

Keep in mind there where hardware and beta revisions to the V2

I had one original v2 cam that I had in service for months with outbound internet blocked. I stopped using it and didn’t get any more due to physical issues with the device and quality control. The focus was blurry and it developed the night vision filter problem as well. Which apparently was fairly common. The v3 came out and I just started waiting for RTSP firmware and for them to become available in my country.

1 Like

@HomeControl is right. I confirm that V2 RTSP firmware works well ALL THE TIME without internet. I have three V2 RTSP cameras that are blocked from the internet and they NEVER disconnect, even after a reboot.
On the other hand, I have four V3 RTSP cameras and they are ALWAYS disconnecting after a reboot when blocked from the internet.
This is a V3 RTSP firmware issue.

1 Like

Thank you both then, that’s very encouraging vis a vis the possibility of switching to local control.

Its still shocking Wyze isn’t incorporating RTSP into v3 by default. I run my v2 on the RTSP firmware so my BI server can keep a couple weeks of 24x7 video. I also want to subscribe to camplus, but because its on the RTSP firmware they say it won’t work so I cannot pay them. My assumption currently is the v3 would have the same issue so why bother upgrading to the v3. I always thought businesses would want more money, but its becoming clearer with each passing year that Wyze doesn’t really understand business, you must make your customers want to come back and buy more from you and upgrade as often as they can afford, which is what they would do because you give them what they want. There are so many thousands of posts about RTSP you would think someone over there could see lots of folks want it. And many of them, like me, probably want to subscribe to CamPlus too. Shortsighted, is the word that comes to mind…

1 Like

I’m pretty sure I’ve read that people have successfully used CamPlus with RTSP. There was some kind of workaround required in some cases, I think subscribing before switching firmware.

I run mine with RTSP and CamPlus. I did have the subscription active before I moved one cam to RTSP. But I added the person detection that they offered recently to two others after. All seem to work fine. Obviously you can’t have the cams blocked in that case since the AI detection is cloud-based.

1 Like

So I can’t get the firmware to flash…

I have a new v3 and set it up to make sure it was working. Downloaded the .zip and pulled out the .bin, checked that the name was demo_wcv3.bin and dropped onto a card. Plugged in while holding the setup button and got the setup loop. updated firmware (several times to get to the latest… which seems weird) and tried again with same results. pulled the card and it has some video and images on it (was completely blank) so I feel like it’s working fine but tried a different card with same results…

Anyone have any tips? I’m not sure what to try from here

The light is doesn’t go purple.
It’s kinda blue then a secondary red light comes on.
When you see the red light come on thru the blue shade let go of the button. Its kinda quick.

Unfortunately that doesn’t happen at all