Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

I did all of the same and got the same result. The cameras will update f/w through the app and the purple light does work with that method. Just can’t load the beta f/w with the sd card.

For me, going through all the motions appeared to fail, No purple light. Sounding of the Ready to Connect message, etc…

BUT… when I re-booted the camera Settings → Advanced → RTSP was at the bottom of the list

clear sailing after that.


Nope, still not working for me. I have probably attempted the update 30+ times at this point. On the latest Android release, no RTSP option and firmware still shows non-rtsp version number.

I was able to do the RTSP firmware upgrade with a 128gb card from microcenter. I think the issue is you have to let the wyze v3 format the SD card. As soon as i did that, put the .bin file into the root directory of the SD Card, it performed the RTSP upgrade as documented. That being said, RTSP has been rock solid for me and love the better quality on the v3 in comparison to v2.

I have installed the firmware and I have the option for the RTSP. I cannot get it to work on streaming devices. I used VLC as a simple steaming device on my Ipad and on my PC. I have turned it off and back on again and re downloaded the firmware. it is interesting that the IP address is not one on my network. Any help would be appreciated. I want to purchase more camera but I need the streaming to work first

This is the command I use with VLC in Windows

“C:\Program Files\VideoLAN\VLC\vlc.exe” rtsp://ACCOUNT:PASSWORD@"

Replace ACCOUNT and PASSWORD with whatever you have set and use the right IP address as well. Make that work first. I have 3 v3 cameras on Tinycam Pro on my Android tablet and I have them streaming pretty much all day on the tablet. No problems.

Also make sure your cameras are on a static IP. Otherwise they may get a new IP from your router and the connection will not work anymore.

Thanks for responding. I did set it up and used a rtsp address like you indicated. The weird thing is this. My router is addresses are the typical…
The camera says it has an IP address of That is not in the range of my router and I can’t find it anywhere. If I ping that address it comes back no reply

I just set up a simple user name and password on my camera
See if you can stream

I will take it down after you reply
Thank you

Are you perhaps using Bluestacks, a VM, or other emulator?

Something handed out that .20 address.

Or are you connecting the camera to a Guest Wifi of the router? Or using AP isolation so that the Wifi client can’t see the wired clients? Or using a wifi extender that forms its own network isolated from the router’s? So many ways for this to happen…

1 Like

I can’t find the camera on my dhcp client list. i do not have ip isolation turned on. I am using an Asus airmesh system; however the camera is located where my main router is located. I can see connected foscams

I would reset the camera and make sure it joins your home SSID.

1 Like

I just reset it and made sure it is on my desired ssid but it displays that ip address that is out of range. I do have firmware installed

using Bluestacks/TinyCam i’ve been able to connect to my cams using Cloud and RTSP/TCP (using default Web & RTSP port numbers), but i can’t figure out how to use RTSP/UDP…how is the setup for this protocol different from RTSP/TCP?

Here is what I did … and it worked!
setup the Wyze Cam 3 as normal
put a 8 gb flash card in the camera
let the camera format the drive
removed the flash drive and copied the new firmware to it
unplugged the camera
put the flash drive in, held down the button
blue/purple light came on after a few seconds and stayed on

after a while , the camera restarted and showed up working in the app
settings/advanced settings, RTSP showed up!
created a user/password and let the camera generate the url
copied the url and pasted it in chrome browser on my computer
let VLC open the link

Regarding RTSP work the v3 cams and Hikvision NVRs, why do you suspect it’s an audio issue?

The v3s show a black window on Hikvision NVRs via RTSP, but v2s are fine.

I’d like to try to get this to work, but stuck.

I loaded the beta f/w on my v3 and am trying to get it to work with Frigate/Home Assistant, However, the image freezes frequently. When not frozen, any motion causes the entire stream to blur and lag severely. The camera is sitting directly new to my access point and has no issues connecting to the LAN (speed/signal) or internet (firewall). I have tried accessing the camera directly via VLC to eliminate Frigate, HA, and the hardware its running on, and have the same issues.

Note: I have read this entire thread and have seen this mentioned a couple times but the conversation always seems to come back to the issues with BlueIris. Would like to see more regarding issues/using this with other NVR softwares.

What does your m ffmpeg options look like? I have the firmware on a v3 not very close to access point and works fine with frigate/HA. Also, what fps are you using in frigate.yaml? I run 5 fps @ 1920x1080

  global_args: -hide_banner -loglevel fatal
    record: -f segment -segment_time 60 -segment_format mp4 -reset_timestamps 1 -strftime 1 -c copy -an

I can confirm that all three of my v3’s have severe issues with live audio both on the stable and beta releases of firmware. The audio on my v2’s on the same network works great. This is occurring on both the stable and beta firmware for months with many updates since. I hope a solution is provided soon as the audio appears to be the only short-coming with the v3’s.

Severe is an understatement.

All my v2 RTSP cams work 100% with my Hikvision NVR, yet my v3 RTSP cams won’t show an image at all. I am trying to debug, but have yet to determine root cause. All other software seems to stream v3 RTSP (VLC, ffmpeg, Surveillance Station, VSplayer), yet a Hikvision NVR won’t display the image.

I suspect it may be due to the audio stream, or the lack of WebRTC, but who knows. I would really like the v3 RTSP firmware to work with my NVR, but am forced to use docker-wyze-bridge for the time being.