Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

Pretty simple way is to set up a new router or guest segment and let it have your existing SSID to keep talking to the Wyzecams. Then configure your new main router / AP as desired. Easier to change settings on PCs and game consoles than on smart home automation devices.

Can’t you save the cameras configuration in your current BI setup to a backup drive then import them once BI is re-installed on your new machine? Or perhaps I don’t understand exactly what you are trying to do. Sorry.

Yeah… I can do that…but my concern was will BL allow to reinstall the software on a new machine and use the same license.

The issue I am facing is that the bl machine is in a completely different place from were the router needs to be… so running ethernet from that wireless router to the bl machine is the dilemma. .Powerline adapter doesn’t work too well because the the wiring is not that great.

As I mentioned, if BI doesn’t work using the same license, Ken will give you a new one if you are a subscriber then he will disable the original one. He will also be happy to give you tips on doing what you want to accomplish.

I’m quoting myself now…scary…

I moved this camera back to my desk much closer to the wireless router, it made no difference right away as of last night. Today, I come home after work, check Blue Iris, and the Camera magically is talking to BI again via RTSP:

image

and I made no changes to BI, or the Camera.

@WyzeGwendolyn @WyzeTeam how do I go about engaging with someone at Wyze to share the log on this camera to attempt to resolve the issue with this one V3 while running the Beta Firmware? I opened a ticket with standard tech support, and they seemed unaware of the Beta, or how to support it.

Do I have a defective camera that needs to be replaced?

Thank you,
SJ

Amcrest relabels famous-name cameras like Dahua, so it’s probably a decent camera, if a bit dated.

The “Starlight” handle means different things, depending upon the vendor. For the most part, it seems to have been based upon back-illuminated CMOS image sensors by Sony, which Sony called, “STARVIZ” at some point. Camera manufacturers then came up with their own similar trade names. For example, Dahua has had, Starlight, Starlight +, Night Color, and now Night Color v2. The sensor and the lens are important factors, but even so, without powerful noise-reduction schemes, it looks like a snowstorm.

I’m not sure what I;m trying to say unless it’s just that there is a lot of room for variability within the term “Starlight”. I know Dahua best because I sell them, so I can tell you that the original 2MP Starlight models were fairly similar to the V3. Higher resolutions (typically) mean smaller pixels, so a 5MP camera will not find as much ambient light as a 2MP camera, all else being equal. Move up to “Night Color” and a dimly-lit street scene can look like day. It’s pretty amazing.

But also fair to say that the technology (beyond the sensor itself) needed to turn night into day does not currently make it into sub-$100 cameras - V1 Night Color models only now getting below $150 with the recent launch of the v2 models, which are literally 10x the price of the Wyze V3. So while they ARE amazing, it’s not really a fair comparison.

1 Like

Hello, I have installed the new rtsp update on Wyze Cam V3 successfully, Generated the url and then tried to play this in VLC. It fails. I have looked at all the helpful hints but it doesn’t seem to work.
The user name and password work as I am successful in installing them into Milestone Xprotect but they don’t stream. I wasn’t surprised that they didn’t stream as it would not if VLC wasn’t working.
Need help please?. I have successfully installed the Cam V2 into Milestone so this isn’t my first go round.

Try restarting your app or your phone.In the past I had a similar issue: tried to open a broken RTSP address. VLC obviously fails. I closed VLC and introduced a working address however its background process still tries to open my old broken stream/address. By killing its agent or restarting the phone VLC will work well on a good RTSP stream/address. An easier workaround would be using the MX Player

I have tried that but still no go. Thank you though

Have you tried restarting your phone? Closing vlc and reopenig it won’t do the trick

I set up logging on my VLC.
errors are not very descript.
live555 error: Failed to connect with rtsp://192.168.1.195:554/live and
satip error: Failed to connect to RTSP Server 192.168.1.195:554
access_realrtsp error:cannon connect to 192.168.1.195:554
So anyone have an idea what is going on?

Dumb question department. Is your computer with VLC and the cameras on the same LAN?

2 Likes

Yes they are.

So I have 2 Wyze Cams v2 working great and now I have a V3.
Issue I have is my HikVision Security complains that the V3 Bitrate is too high.
Is there a way to lower the bitrate the cam puts out. I know it’s a strange question.

I received my Amcrest IP5M-B1186E (5MP, outdoor, POE bullet cam). After some stumbles on the start-up learning curve it works with tinyCam, VLC, ffmpeg and the Home Assistant Dahua HACS integration. No learning curve required for tinyCam :wink:

Your comment about the loose meaning of “Starlight” help reset my expectations before I experienced any disappointments.

I mounted the Amcrest camera just below my Wyze V3 (painted black) on a fence post that looks down my driveway:

Here’s an “over(Wyze)-under(Amcrest)” comparison at 17:24 EST. Still daylight (tinyCam screen capture from my phone)

Same at 18:37 (with lights on at the gate post)

Just 2 minutes later at 18:39, the Amcrest has switched to IR mode. (a clear win for the Wyze Starlight Sensor)

At 21:10 some exterior lights on.

Finally at 23:16, all lights out. Just a full moon for illumination. IR lights off.

Even with the IR lights disabled (in a attempt to eek out more color) on the Amcrest, the Wyze remains a clear winner on color night vision.
However, Amcrest is a clear winner at capturing readable license plates as vehicles enter and leave.

At this point I’ll let the IP5M settle in before I purchase a second camera for an up-the-driveway view.
Once I get a 2nd IP5m I will redeploy the Wyze V3s to other exterior locations closer to the house.

4 Likes

Those are some fun comparisons…I love stuff like this! Part of the reason the V3 works as well as it does in low light is the lower resolution/bigger pixels, but I feel like they also sneak the shutter speed way down too. You might get similar results with the AmG8 if you dig into the the settings in the web interface and figure out how to reduce the minimum shutter speed.

2 Likes

OK… last test :wink:

I set the shutter speed to 1/30 (33.33 ms). That’s as slow as it goes.
Wyze V3 wins… (it also looks like 1/30 is the nightime default with IR=OFF, Fence Post Light=ON)

2 Likes

This is great stuff, @YetAnotherDave . Thank you for it. I can’t help wondering if there’s a setting to keep the Amcrest from entering IR mode and see what the results are.

Also, in each of your samples the Amcrest is pushing a bitrate two or THREE times higher than the Wyze next to it. I suppose it has to in order to approach 5 MP but that’s impressive.

1 Like

In the image above, IR=OFF, BLC=OFF. I also tried BLC, HLC & WDR, lowest shutter speed, etc, but could not find a combination that allowed for “color” in the same low-light environment where Wyze V3 worked. Lowering the screen resolution didn’t help “brighten” things up either. I don’t know if Wyze has a better sensor or has better low-light optimization with the same sensor.

High bit rate: Yes, resolution 2592x1944, 15FPS. I haven’t figured out how to access the substream with tinyCam, but tinyCam is not my primary viewer (just my universal viewer).

My last comment :wink: on this subject is that I had feedback from both the Amcrest forum and official support e-mail to help me through my start-up issue using ffmpeg. With Wyze I’ve had ZERO response from support even after messaging the Wyze forum mavens directly.

ffmpeg is a surprisingly high priority for me. I pull an image every 15 minutes from 9:00 to 15:45 everyday. Every 3 - 12 months I make a small video to watch the grass grow, the snow fly, whatever.

If anyone has gotten ffmpeg to work with the V3 RTSP Beta code, please post your success on this thread.

Thanks!

1 Like