Beta Testing for Wyze Cam v3 RTSP Firmware Now Available!

Good question. However, if you setup CamPlus BEFORE you flash for RTSP, the camera will continue to have CamPlus after flashing for RTSP. That works for Pan, V3, and V2.

Look at post 58 in this thread. I posted screen captures of my BlueIris setup. Not making any effort to record or monitor audio on BI.

My screen shots from Blue Iris v4 are on post 50. Since this thread is so long already, I’m hoping someone might collect or create an index telling where the working screenshots can be found. I think this would be a useful resource for people getting started with the beta.
No audio for me.

I think that’s a great idea @tahoejeff, but the trouble is that Wyze has yet to give us any advice or feedback on Blue Iris configuration, so as a result, nobody has a fully-functional configuration. And even people like me who have it working to some extent are experiencing difficulties. And does anyone have audio working? I don’t think so.

I’m new to Wyze, so I have to ask, is the way they typically roll?

If I understand where you’re seeing that in Blue Iris, I’m of the opinion that the number is more like an indication of peak framerate than a setting. I know that looks and behaves like a setting, but I also know that I’ve never seen my setting stick. Assuming that’s true, then maybe the camera and/or the network connection falters at times, such that frames get piled up, then come through in a rush, which pushes the framerate up in Blue Iris. That’s complete speculation on my part.

I’ve had 3 v3 cams running RTSP to Synology Surveillance Station (both video and audio) stable since initial set-up, for 8 days now. Saw a couple others here running Synology without issues too, but don’t think they specified audio.

Has Wyze’s position on the RTSP firmware changed, or is it still “this is beta, you get what you get”? After dealing with that on the v2 I haven’t exactly been eager to adopt more cameras.

Alright so im having some issues with my POS cam v3. After placing the demo_wcv3.bin onto the root of the sd card and struggling for 15m with the retarded sd card slot i powered on my pos cam v3 while holding the setup button. I hear the camera click as if its restarting then the voice says “ready to connect”. i go through the setup process but it never actually flashes the firmware onto the camera. Also just trying to unplug the camera at the small white extension at the camera the damn metal male part actually pulled out of the cable.

UPDATE: Just got off the phone with wyze amazing foreign support team and not understanding a damn thing they said to me. They said they would email i think i couldn’t really tell. Very easy process. Just sat on the phone pretending to understand what was being said for 45 minutes for the call to end with we will email you instead. So i guess in about 3 months i should be receiving an email. Ill update then.

Not sure why you had trouble with teh uSD card slot - it’s just a standard uSD card slot - unless you were trying to put the card in backwards (and yes, it is backwards compared to the V2).
If it said “ready to connect” the uSD either could not be read (must be no larger than 32GB for flashing), or the file was not readable (or the right name). One of the more common issues is that Windows by default hides the filename extension so when you name the file demo_wcv3.bin because the extension is hidden you actually named is demo_wcv3.bin.bin - which will not work.

There is only one direction you can put that card in, so not sure what kind of issue you have with the slot, unless something is blocking it.

To upgrade, it was pretty easy. Hold down the Setup button while power on the cam. Once I see a purple light, I let go of the setup button. After a few minutes, I check the app and go under Advanced to turn on the RTSP.

Make sure the sdcard is formatted FAT32. I had mine formatted exfat and it was working fine for camera storage, just doesn’t work for firmware upgrades.

1 Like

I never saw the light turn purple… I tried “setup” several times, I finally tried the App, the RTSP option was available and it all works.

I’ve got 2 more cameras to setup. I’ll look for “purple” but it’s not a prerequisite as far as I can tell.

I had a very similar thought…hard to open, backwards, finicky…anyway, thanks for the laugh!

Yeah, my first V3 came with a defective USB cable right out of the box. Had to spend an hour of my life to get it replaced at no charge to me, which was stupid, because my hour should be worth more than the cost of cable!

On the rest, as @Wahapainan and @K6CCC said, the card has to be formatted FAT32, That caused my first attempt to fail. And as @user1010111 pointed out, one has to find a way to hold the setup button while connecting power and then hold it down for a rather long time, which isn’t quite as easy as it sounds. Oh, and I’ll second what @YetAnotherDave said - I never saw the light turn purple either.

Lots of “gotchas” in making RTSP work on the V3. And I realize that it’s beta, but then on the other hand, I can’t see that Wyze is interacting with their beta testers (us), so I’m wondering how it’s ever going to get out of beta.

1 Like

I haven’t seen any official statement (or much of anything else) from Wyze, but what you are saying certainly does reflect my own experience up to this point.

So…how/where does one buy Synology Surveillance Station? Can it makes sense for people who are buying $30 cameras?

You can get it if you have a synology device or run their OS on your own hardware from

Thanks, I understand. But for the purposes of the typical V3 buyer, I think it would come down to people who happen to have a Synology NAS. And since those are expensive relative to the V3, I’m guessing that not all that many V3 buyers have one. Or a NAS of any kind. That would make for a fun survey, though.

I just got this message from the forum software:

You’ve posted more than 20% of the replies here, is there anyone else you would like to hear from?

'Kind of sounds like “they” think I’ve already said enough. :grimacing:

Yeah, that was my situation - I already had their NAS, and the Surveillance Station software was free for me to install and use. One other major consideration about Synology however, is that it works on a license per camera model. The software came with 2 free camera licenses, but any number of cams beyond that requires the purchase of a license for each. I have need for 3 cams, so I had to purchase one license at $55 ($65 MSRP) to add the third $30 cam…that stung, but in my case was still worth it.

Hopefully this post will drop you below 20% again ;).

And “they” probably haven’t even counted all the private chats we’ve had concerning BI and the V3. :rofl:

Doing some reading it appears that maybe my best bet with my V3 and BI is to use an old router in bridged mode to extend my router’s coverage to the V3 and still remain on the same IP scheme.