Audio out of sync

My audio is often offset by 2-3 minutes on recorded videos. Either through manual recordings or through the SD card playback, the audio track is 2-3 minutes ahead of the video.

A few seconds seems fine but the audio is completely out of whack.

It works fine with live streaming and with the automatic recordings.

Hi,

I’m finding I have a 5 second audio delay with my Wyze Cam v2 (using the live stream setting). This happens regardless if on the 360p, SD, or HD setting.

WiFi signal is strong, and I’ve updated the firmware.

Thanks for letting me know, @FatherJ and Nialz! Please send that information to Arthur by following these instructions:

@WyzeGwendolyn , I have the same exact problem in all my cameras. About 5-30 seconds delay between video and audio both in live stream and in recording to se card or event recording.

This happens with all my 5 five cameras, all running the latest version of firmware and all with above 95% signal strength

Any recommendations as to how to improve the situation? Or are you working on it for future updates?

@WyzeGwendolyn EDIT: Important update! I have checked that if I read the files directly from the SD on a computer then the synchronization is perfect. It seems the problem is reproducing it with the Wyze app. I’m using an iPhone XS Max

Edit2: false alarm. I checked again and I have delays in the files recorded on the SD card as well. Reproducing on a of with VLC still observing a variable amount of delay from 5 to 15 seconds

Well, darn. Thanks for letting me know on all counts! We’re working on these issues so please send the information requested by WyzeArthur over to him. Thanks for your help!

I have an iPhone X and have been experiencing sound randomly shutting off after a certain period of time on the app. Sound randomly turns off after a period of time and won’t come back on unless you mute/unmute or close and reopen the app. Very frustrating as I use this as a baby monitor and it is useless without the sound constantly working and I can’t be muting/unmuting or restarting the app constantly, especially overnight.

I don’t have a great answer for that. But if you would like to send Arthur some of the requested information, I’m sure that will help. :slight_smile:

1 Like

I’m having the same audio sync issues as others in this thread have described. I have sent my information to the email Arthur provided. This needs to be fixed.

Same issue with all 3 cameras I just ordered. They should take a cam out the shelf, seems they all have the issue.

On the top of that…sound is clipping and video is occasionally speeding up suddenly (missing a few frames). Looks like the processor is not up to the task.

I have tried to lower video quality to SD rather than HD, but video is still out of sync. I don’t know why is so hard for them to fix this. I recommended this to a friend and he ordered…I will look stupid when he discovers the issue :frowning:

Same here with the v2 cams. Problem does not exist on the V1. So I assume that it’s not a processor issue. Let’s hope that they won’t break it on V1 cams once they fix it on the V2…

As Qutrit mentioned, it is also present if you play the video directly on SD cards. So the issue is in the cam itself (firmware, processor…).

I had in the past cameras and audio devices connected on a pc . When the computer CPU could not keep up, I had exactly the same issues (sound clipping, missing frames). You might not realize the Wyze is skipping frames but you will for sure if the audio is out of sync. The audio can not shrink itself to accommodate the missing frames so that would create delay (out of sync). This is a possibility.

They probably can not solved the issue in a easy way, It has been 7 months since this post was created.

From a programming perspective this is an easy fix, given the duration of this issue with no resolution, I am banking it being more of an hardware challenge then software.

While it is a great cam, this issue will unfortunately prevent me from buying anymore. On to the next brand !!!

I too have been experiencing all audio sync issues mentioned in this thread

I have 8 camera’s and they all have this issue. Is this ever going to get fixed???

I just noticed when I “Record” a clip from the live feed of my cams the audio is significantly delayed.
It never used to do this.
What is causing this?

Please don’t post the same question in multiple conversations. The responses get really confusing to everyone.

It’s done that the year I’ve first owned a cam. Cloud clips are in sync – most every other incarnation is not. You can sometimes get a captured version mostly in sync, but the only way I’ve found to do that is luck. Capture it several times and see if one is mostly in sync. They will probably be all over the place, but I often get a usable copy with a little effort (using iOS).

Hope they fix the audio issues soon, they’ve been working on the sound problems awhile.

Then don’t have multiple threads…:stuck_out_tongue_winking_eye: That is the one that came up when i did search.
Threads can be merged. It is done all the time on another companies fourm I frequent that uses this exact same software backend.

Anyway, does anyone know the exact ms offset of the audio video…so i can edit my vids?

It varies. If you capture again it may be different, and one of the versions may be ‘almost’ right. Never have gotten one to be right on.

One can not just capture the event again…defeats the purpose of having cams if they dont capture the event right.

Thankfully, I ripped the SD cards out of the cams (now i have to remount the cam…grrr).
The raw files on the SD card are fine, both from my V2s and from my Pan.
It is just when u download the files or use the Record feature on the phone app that the audio is way off.
I had assumed that the “Record” was just a download of the file in real time that is on the sd card, but it seems it is just doing a screen record/capture??

I noticed that one of my cams, the mic stopped working entirely, a plug and unplug(power cycle) fixed that. That was the v2 cam that I accidentally upgraded to beta firmware a few weeks ago and the time stamp no longer works.

The multiple files on the sd card, when I try to append them all together with mkvtoolnix, the audio track is lost entirely…that is odd, as I have remuxed mutiple event video files into one file many times before in the past.

WYZE seems to have some issues with how the cams files are encoded the last firmwares or so…
Making me want to switch to some other cam solution that has better direct acces to raw files.

Thanks for the info on how to get a clean copy – I did not know that!

On capturing the recordings again, I meant capturing them from the card again. As you said, the recording was good, it’s just the delivery that is bad. I knew that varied and you might get one that worked, but I did not know it had recorded a clean copy. Good info!

On the audio dropouts – yes, that is another issue. For me when my audio disappears I can simply mute/unmute, and things are fine again. Of course while the audio is down I don’t think anything is recorded, and that is a permanent loss.

I don’t think anything has changed in any audio coding for some time, but I sure am ready for them to deliver a good, clean fix!