Allow multiple devices to be controlled by a single Schedule Rule

Prior to the changeover from Shortcuts to Rules, a single schedule could be used to control multiple devices. For example, you could turn on/off multiple cameras with a single schedule shortcut. Those rules were imported (grandfathered) into the new Rules architecture;

However, there is presently no way to create a new schedule rule that controls multiple devices. Please add this to the Rules feature.

Yes this. I can’t believe we lost this feature. It’s now a mess to try to schedule things and I can only imagine how bad it would be if you have a dozen or more devices. I actually signed up just to figure out why this option has changed for the worse.

3 Likes

I’m a new owner of 8 cans and a slew of sensors. So i didn’t get to see what got deprecated. I think it be even better if we could just 'call a ‘rule(s)’ that we’ve already created and execute it/them in a schedule…like I used to do in 24 years of enterprise software programming.

I’m trying to do this and it doesn’t work at all. I created a rule to mute notifications from 6:00am to 9:00am and from 4:15pm to 11:30pm but I still get notifications during those time periods.

Am I doing something wrong?

Can you post a screenshot(s) of your rule setup?

image

I have case open with tech support. They are reviewing the log file because everything seems to be set correctly. I start getting nailed with notifications during the entire “mute” period. Their suggestion was to roll back to the prior version or try the beta version which I haven’t done yet.

But basically this means the rules don’t work AT ALL?!

They also suggested just turning off the bell icon…but seriously that sucks…that just means i have to manually turn it on and off, and again the rules don’t work? I must be missing something.

Thanks for any help you can offer.

If you do manually turn off the bell icon, does that stop the notifications?

When the start time of this rule passes by, does the bell icon change from on to off? (It should.)

If the answer to the first question is yes, but the answer to the 2nd question is no, then that does tell us that this rule isn’t working.

I just tested myself and the bell icon goes off when the time passes (after a few seconds). It could be a problem with your particular user account on the server in which case hopefully support will be able to resolve it.

Interesting points you make.

Answer to question 1 yes the notifications stop entirely if I manually turn off the bell.

Answer to question 2 the bell icon does not turn off ie slash thru it during the time periods…

Does this help narrow the issue? Thanks for your help and great ideas

So i actually just ran into this myself. I just bought some new products. Decided to delete my old schedules and start from scratch (which was a bad idea). My old disable notifications worked find. The new one doesn’t. The bell is crossed out but still get everything. If i manually do it seems to work fine.

I, too, would like this functionality restored, As I build out my Wyze ecosystem, I inevitably want to add new devices to these existing scheduled rules, but can’t. With only 1 device action per new rule, the interface becomes instantly cluttered and a mess. (There isn’t any way to arrange/order rules in the interface, either; they appear in the reverse order of how they were created/entered. This inevitably leads to an even more cluttered mess. Are we seeing a trend? The interface is a huge factor in user satisfaction…)

Another way to do this would to allow shortcuts to be scheduled, so that way we can tweak the shortcuts and have them applied at various scheduled times or as other triggers define them. To me, this seems like the easiest solution.