Alexa Person detection announcements stopped working 2

Alexa Person detection announcements stopped working, I tried restarting all 3 echo’s that I have. Cameras still sending iphone text messages.

Any Ideas?

Thanks for any help.

John G

posted similar thread got not official answer, the person detection option magically disapeared from the alexa app, I got no reply guess they are too busy releasing a bunch of new products

1 Like

This is a big issue for my setup as well. Tried deleting the cameras and rediscovering in alexa and removed alexa Wyze skill and reinstalled. What is going on Wyze

I’m not seeing that issue, the options are all present and accounted for

For me it only works on the outdoor cam, The option disappeared for my other two cams.

Here is the cause, a minor, temporary work around, and updates that I have received from Wyze and Amazon.

  1. the issue is that cams on the PD program (pay what you want PD) will suddenly be unrecognized by Alexa as PD capable.

  2. cams on the Cam-Plus program will always be recognized by Alexa as PD capable, and will not lose that recognition.

  3. the only temporary work around is to rename the cams in the WYZE app to another name (simply adding or removing a space suffices), this will immediately cause Alexa to see the cam as PD capable. Note: this is true, even if cams running the RTSP firmware.

  4. this temporary fix only lasts a short time before reversion to non-PD capable status again. This will break any Alexa routines using the PD as a trigger, taking them offline, losing any announcement ability.

  5. Amazon arranged a three way call with myself and a Wyze Wizard. Amazon stated that this issue is on the Wyze side, not Amazon’s.

  6. Wyze followed up with me, verified that my network was perfectly functional and adequate, that firmwares were current, etc. and advised me that they would, once again, advise the appropriate engineers that this issue needed addressing. I have not heard any subsequent updates (2 weeks ago).

Summation:

There is a known issue that causes whatever backend feed to Alexa that allows Alexa to see the Cameras as PD devices to drop out. The issue only effects those on the PD program, not the Cam-Plus program. There are no known fixes at this time.

2 Likes

Thank you for this update. I had a routine in use which is now broken. It allowed me to know when packages arrive so I don’t get porch pirated. I hope they fix this soon. My cameras are constantly buffering on alexa devices as well. I switched from the Google ecosystem to Alexa because Wyze could never get Google Assistant integration working well, now Alexa is broken :man_facepalming:.

1 Like

Thanks for linking me here. This is interesting.

Strangely, until this week I had all cams on the PD program (no CamPlus) and 80% of them worked fine 100% of the time, only 20% ever had problems. You’d think they’d all have problems or none would. Makes no sense it’s inconsistent and only a couple of the cams have issues. Still, I’ll try the trick, especially since I plan to keep CamPlus on those outside cams now anyway (they currently aren’t showing up even with CamPlus on them).

wyzegwendolyn ; I don’t have any cams on the PD program, just the Cam-Plus. Two of the five won’t show up as having the person detection. Deleted the v2 which have Cam-Plus cameras from Alexa and then did discovery. Still didn’t show person detection capabilities.

What’s interesting is that all of my WCO cameras which doesn’t have Cam-Plus are showing up in Alexa as having person detection. So the last WCO firmware update enabled Cam-Plus features on Alexa without Wyze having the service on them. 4.17.0.186

So go figure, the cameras with the service don’t all work and the WCO which don’t show up in Alexa as having the service. Just tested them. It didn’t trigger the ALEX routine when I got the motion alert on the WCO. So PD shows up in Alexa but it is not functional.

Posted this feature of 4.17.0.186 WCO firmware on post that announced this firmware release.
Just noticed that my user ID had an extra “e” when I logged back in.

I tried this multiple times.

I tried just changing the name in the Wyze App, and nothing else. Still no PD capable, but Alexa recognizes the name changed.

I deleted it from Alexa then changed the name then told Alexa to add it again. No PD capabilities in Alexa still.

I changed the name then deleted it from Alexa, then Told Alexa to look up the cam. No Change.

This is not my experience. I added cam plus on the cam and tried the above steps again, still no PD options in Alexa even with Cam Plus active on it.

PD works fine through the Wyze app on that camera. Everything appears to be working great, except that Alexa won’t recognize it as having PD options no matter what I try, even with Cam Plus. Just thought I’d give an update that none of that worked on my South Side cam, but PD definitely works through Wyze directly.