Alexa fails on Wyze band

I finally connected my Band to my phone, I have location services on in the Alexa alerts section of Wyze app. Wyze app says ready to,use Alexa. On the band Alexa always returns “no response please try again”. In the Alexa app on my phone, my band shows up as a device, under activity in the Alexa app message says “welcome, Amazon is excited to bring you Alexa on Wyze Band”. Wyze band is listed on device list as online and location services for the band under device settings for the band in the Alexa app is turned on. Why doesn’t Alexa respond on my band.

MODERATOR NOTE:

This topic has been moved to the #early-access forum category. Please keep all discussion of Early Access products here until the product(s) have been publicly released.

If an Early Access purchaser needs to join the Early Backers group, please go to the group page at the link below to request access.

https://forums.wyzecam.com/g/EarlyBackers

Try going into the Alexa app, going to skills and disabling the Wyze skill. Wait a few minutes and re-enable it. Then let Alexa discover devices, look at your devices and make sure that you don’t have a duplicate Wyze Band listed.
You may also have to reboot your Band and go into your device settings/bluetooth and tell it to forget the Wyze band. It will then reconnect bluetooth.
This is kind of new for all of us. I’ve had to play around with all of this and go thru these steps. Eventually it works, but I’m not sure of the most efficient way to do it yet. Sorry - hope this helps!

1 Like

Thanks, I’ll give it a try.

Mine was doing this same thing, then out of the blue it started working.

i did what you did… nothing.
and i got a firmware update and also rebooted after that.

no response at all

but really how does it work? i tried taping the blue button for a few secs and then saying … alexa turn off library lamp 3 and nothing happened.

is there some secret trick ?
this is frustrating.

Wyze band is showing in alexa devices and i also disabled and reenabled the skill as well

nothing

First off, let’s all remember we are early access for a reason, to beta test this device. Problems are to be expected. Here are the issues I have encountered.

  1. Initial connection with android was impossible. I had to connect to my iPad first then turn off iPad Bluetooth , turn on Samsung note 3 Bluetooth and then it connected.
  2. Band fails to reconnect if you leave Bluetooth range of phone and then return. It never shows up as a previously paired device on my phone Bluetooth list. Even my 10 year old car automatically reconnects with my phone without any intervention an my part.
  3. Only some notifications come through (Wyze devices only) to band in spite of setting phone, text, mail etc. in notifications under settings in Band device in Wyze app.
  4. Alexa activation on Band always responds “listening”, “no response please try again”. Band shows as online in Alexa app.
  5. run mode on band does not track distance or time accurately, 3 mile run displayed as 0.2 miles.
  6. Shortcuts are set up on Wyze app using mute and unmute. Do not display on band.
  7. Battery level does not display on Band only in app, set as on in app settings, tap 3 dots upper right of app display “more” level listed as 67%. Band has been on continuously since April 21. Of interest none of the available clock faces display a battery level option.
  8. Sleep timing under activity started working on April 24. Amount of deep or light sleep not quantified, only graphed.
  9. Run history is inconsistent however calorie usage is recorded for the missed runs. Step count seems adequate.
  10. Run setting in app does not notify band with vibration at 1 mile and receive notification setting sometimes turns off by itself.
  11. Alarms work as intended
  12. Weather works as expected.
  13. Heart rate works, Find works, Settings on band work,
  14. Alexa alerts: timers, reminders, alarms, don’t display on Band

Some people have their bluetooth off or vice versa their wifi off, I ended up locked out of my house with only my Wyze Band, I really hoped that Alexa would not fail me and thank God my phone wasn’t too far like upstairs. I think I should test the distance of the phone and using alexa and see if their are any situation.

any update on fixing the Alexa feature ?

I have had no issues with alexa, it must be your phone or how you setup alexa. I was able to unlock my door with the watch.

MOD NOTE: Post edited to conform to the Community Guidelines.

When using your Wyze Band don’t use the Alexa Wake word. For instance if you use an Echo device you are probably used to saying something like “Alexa, turn on the bathroom lights” with the band you would just say “Turn on the bathroom lights” at the “listening” prompt from the band.

Have tried with and without wake word, have reset band and re-signed into Alexa through the Alexa app, band shows as online in the Alexa app, Alexa is activated and “ready to use” in the Wyze band app. All I get is “ listening, no response, please try again”.
Alexa alerts also don’t work.
There are several other issues but I’m trying to concentrate on this one problem for now.

Probably not your issue but I have found that speaking like a robot with no fluctuation or intonation at all, one word at a time with a short pause between, definitely improves the success rate.

1 Like

On mine that feature works. I believe it’s in the App(Settings/Show Battery Level), independent of the limited clock faces.

  1. Battery level does not display on Band only in app, set as on in app settings, tap 3 dots upper right of app display “more” level listed as 67%. Band has been on continuously since April 21. Of interest none of the available clock faces display a battery level option.

Thanks for the photo. At least it works on some bands. I have tried multiple clock faces, turned on and off “show battery level” on band in settings several times, rebooted the band several times, won’t work on my band with most recent firmware. It’s funny how some things work and others don’t . I have discovered that on my phone, Samsung, the preinstalled apps for mail, calendar, text messages and probably others, won’t send notifications to the band. Third party apps will send notifications to the band,

You have stumbled onto Androids greatest strength and weakness. It’s an incredibly rich and open platform that welcomes and encourages developers to extend and enhance it. But it also does far too little in terms of enforcing adherence to standards.

Samsung has chosen to develop and deploy a “skin” for their phones that purposely does not follow the Android standards. At least no more than they have to. Without rooting your device you are stuck with it. So has every major Android phone manufacturer. At the moment only the Pixel phones offer current “stock” Android experiences.

This usually works fine and can even bring neat features to your phone. Where it falls apart is when someone tries to integrate their product into 93 different vendors environments.

1 Like

Update:
Referring to my list of issues near the beginning of this topic, the following changes have occurred.

  1. Connection issue persists. After resetting the band I still had to do the initial connection with my iPad as the 4 digit number was not recognized on my phone.
  2. Continues as major issue.
  3. Getting better, native Samsung apps won’t communicate with band
  4. Persistent problem, no Alexa integration at all.
  5. Now works.
  6. Now works.
  7. Still no battery level displayed on band.
  8. Now works.
  9. Improved response.
  10. No run notifications on band when enabled in app.
  11. All Alexa features non functional.

I would look for a replacement. Things like Alexa not functioning and no battery indicator would seem to indicate a defective product.

I would open a support ticket and ask for a replacement.

1 Like

just did the latest upgrade and re connected with alexa … it was showing offline before the latest upgrade… still nothing happens when speaking to the band either pressing alexa alerts or not and not saying alexa wake word. also lift to wake does not work consistently.

1 Like

I sympathize, mine works acceptably but I do have to take care that the display is actually saying listening before I say anything.

1 Like