+1 for being unable to connect my vacuum to my network

I have tried factory resetting the vacuum, an iPad and Samsung phone and two different networks. I have confirmed that my SSID is only broadcasting on 2.4 Ghz. It just sits at Connecting... and never goes any further. I was pumped to use this thing. Very disappointed to see that no one has found a solution. Help.

Just a hunch, as I’ve been burned by this a few times. On your phone (I’m not sure if your iPad is on a phone data plan, or not), you’ll need to disable “Mobile data” when you’re trying to connect any device that creates a wifi hotspot to set things up. If not, it’ll continue trying to connect.

Hope that helps.

I responded on the other thread, but try uninstalling and reinstalling the app. It worked for me.

I finally got it to connect. I had mobile data turned off and turned off auto-reconnect from all of my networks. Put in the password for the network that I wanted it to connect to, connected to the vacuum network (both steps that are in app) once I connected to the vacuum network I went to the app and verified that it was “Connecting…” then flipped back to the wifi settings in my phone and opened the vacuum network settings and kind of hung out in there and it connected almost right away.

1 Like